Bug 1804831 - Don't deprecate v1alpha2 OperatorGroup
Summary: Don't deprecate v1alpha2 OperatorGroup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Alexander Greene
QA Contact: Jian Zhang
URL:
Whiteboard:
: 1804950 (view as bug list)
Depends On: 1798051
Blocks: 1780378
TreeView+ depends on / blocked
 
Reported: 2020-02-19 17:31 UTC by Alexander Greene
Modified: 2020-05-13 21:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:59:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1303 0 None closed [release-4.4] Bug 1804831: Reinstate v1alpha2 operatorgroup 2020-10-26 09:48:57 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:59:19 UTC

Description Alexander Greene 2020-02-19 17:31:55 UTC
This bug was initially created as a copy of Bug #1798051

I am copying this bug because: 



When we added structural schemas, we inadvertently dropped v1alpha2 operatorgroup. This wasn't communicated as a deprecated api, so we should not remove it from 4.4.


4.3 still has the v1alpha2, but this backport PR needs to be updated to include it before it can merge: https://github.com/operator-framework/operator-lifecycle-manager/pull/1197

Marking the related bug blocked on this one.

Comment 1 Nick Hale 2020-02-19 23:54:42 UTC
*** Bug 1804950 has been marked as a duplicate of this bug. ***

Comment 5 Jian Zhang 2020-02-21 07:41:38 UTC
Cluster version is 4.4.0-0.nightly-2020-02-20-223401
mac:~ jianzhang$ oc exec catalog-operator-75c9f6d98d-jrx42 -- olm --version
OLM version: 0.14.2
git commit: 3d7f04faecb0072e72858b67af34232f854a17cc

1, Create an OperatorGroup object with the v1alpha2 api version.
mac:~ jianzhang$ cat og.yaml 
apiVersion: operators.coreos.com/v1alpha2
kind: OperatorGroup
metadata:
  name: test-og
  namespace: default
spec:
  targetNamespaces:
  - default

mac:~ jianzhang$ oc create -f og.yaml 
operatorgroup.operators.coreos.com/test-og created

mac:~ jianzhang$ oc get og -n default test-og -o yaml
apiVersion: operators.coreos.com/v1
kind: OperatorGroup
metadata:
  creationTimestamp: "2020-02-21T07:39:13Z"
  generation: 1
  name: test-og
  namespace: default
  resourceVersion: "35323"
  selfLink: /apis/operators.coreos.com/v1/namespaces/default/operatorgroups/test-og
  uid: 7b387029-fc43-4c88-89d8-2fbd07af5388
spec:
  targetNamespaces:
  - default
status:
  lastUpdated: "2020-02-21T07:39:13Z"
  namespaces:
  - default

The OperatorGreoup works well, LGTM, verify it.

Comment 7 errata-xmlrpc 2020-05-13 21:59:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.