Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1804957 - Web Console ConfigMap links not processed with certain operations
Summary: Web Console ConfigMap links not processed with certain operations
Keywords:
Status: CLOSED DUPLICATE of bug 1782695
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.11.z
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 00:22 UTC by Takayoshi Kimura
Modified: 2020-02-21 00:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-21 00:26:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Takayoshi Kimura 2020-02-20 00:22:56 UTC
Description of problem:

In Web Console, open a project ConfigMap list, move somewhere else (click other menu items or dig into a configmap item) then hit browser back button, the all configmap links get broken and become links to /console/.

Version-Release number of selected component (if applicable):

v3.11.161

How reproducible:

Always

Steps to Reproduce:
1. Open project ConfigMap screen like /console/project/default/browse/config-maps
2. Click any link on the screen
3. Hit browser back button
4. Confirm ConfigMap links get broken

Actual results:

All ConfigMap item links get broken, links to /console/

Expected results:

All ConfigMap item links go to ConfigMap item properly

Additional info:

Comment 1 Takayoshi Kimura 2020-02-20 00:26:13 UTC
Workaround is to reload the ConfigMap list screen, it fixes the item links.

Comment 2 Jakub Hadvig 2020-02-20 13:15:22 UTC
This looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1782695

Could you please check the version of the web-console image so we can check if it contains the fix or not ?

Comment 3 Takayoshi Kimura 2020-02-21 00:26:12 UTC
Thanks, indeed this was duplicate. The issue fixed by updating the web-console image to the latest one which was released yesterday.

*** This bug has been marked as a duplicate of bug 1782695 ***


Note You need to log in before you can comment on or make changes to this bug.