Bug 1782695 - Redirection for config map is not happening correctly [NEEDINFO]
Summary: Redirection for config map is not happening correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.11.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1785752 1787185 1789136 1795409 1795738 1804957 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-12 07:14 UTC by Aditya Deshpande
Modified: 2020-04-28 01:44 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Since we started to retrieving the PartialObjectMetadateList for ConfigMap list page, we need to tell to the navigateResourceURL filter explicitly that we need URL for configmap resource, since the resourceURL service function is aware about first-class resource, not the PartialObjectMetadate that is used. Consequence: Redirect to the console page, instead of ConfigMap details page. Fix: Supply the navigateResourceURL filter with kind and name space in the ConfigMap list page. Result: Redirect will happen to details page of picked ConfigMap.
Clone Of:
Environment:
Last Closed: 2020-02-19 19:53:43 UTC
Target Upstream Version:
adeshpan: needinfo? (jhadvig)
adeshpan: needinfo? (jhadvig)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin-web-console pull 3161 0 None closed Bug 1782695: Supply the navigateResourceURL filter with kind and name space in the ConfigMap list page [enterprise-3.11] 2021-02-21 19:53:33 UTC
Red Hat Knowledge Base (Solution) 4708761 0 None None None 2020-01-02 12:04:59 UTC
Red Hat Product Errata RHBA-2020:0402 0 None None None 2020-02-19 19:53:57 UTC

Description Aditya Deshpande 2019-12-12 07:14:57 UTC
Description of problem:
First time after logging into web console, clicking to config map is redirecting to the correct page and showing the yaml file.

Select-project ==> Resources ==> Config Maps ==> get the list of configmaps.

Right click and check the link location which is pointing to the correct URL and will show the correct yaml after clicking one configmap name.

First time correct URL:
https://openshift.test.com/console/project/<project-name>/browse/config-maps/cluster-monitoring-config

Again if we go back to Config Map list and check by right clicking then it will show URL as below and clicking on config map name will redirect to the console page.

Checking back and forth, URL is:
https://openshift.test.com/console/


Version-Release number of selected component (if applicable):
V3.11.154

How reproducible:
Always

Actual results:
Clicking on configmap name is not redirecting to the yaml file and redirecting to the console page.

Expected results:
It should redirect to correct yaml of configmap irrespective of going back to the list and checking yaml file again.

Comment 2 Jakub Hadvig 2019-12-16 21:48:06 UTC
Not really sure about the reproduction steps and their meaning.

Could you please provide step by step actions, since the one in the description are not clear to me. Thanks!

Comment 3 Aditya Deshpande 2019-12-17 04:54:58 UTC
1. Go to any project having configmaps as follows:

Select-project ==> Resources ==> Config Maps ==> get the list of configmaps.

2. Click on any configmap and it will show you the respective yaml file.

3. Go back to configmap list
   Click on "Config Maps" written in left upper corner.

4. Click again on any configmap, it will redirect to the main console page.
   Before clicking on any configmp, do right click and check the copy link location:
    This will give you URL as https://openshift.test.com/console/

So, the problem here is that clicking on configmap(second-time) is not redirecting to the correct page showing the yaml instead it is redirecting to the console page.

I am attaching the screenshots.

Comment 7 Jakub Hadvig 2020-01-02 12:04:59 UTC
*** Bug 1787185 has been marked as a duplicate of this bug. ***

Comment 10 Jakub Hadvig 2020-01-09 11:01:06 UTC
*** Bug 1785752 has been marked as a duplicate of this bug. ***

Comment 11 Jakub Hadvig 2020-01-14 21:33:34 UTC
*** Bug 1789136 has been marked as a duplicate of this bug. ***

Comment 14 XiaochuanWang 2020-01-19 07:13:24 UTC
Follow steps by https://bugzilla.redhat.com/show_bug.cgi?id=1782695#c3
The step "4. Click again on any configmap" takes user to the configmap detail page which is expected.

Verified on OpenShift Master / Web Console: v3.11.165

Comment 16 bpeterse 2020-01-28 15:52:24 UTC
*** Bug 1795409 has been marked as a duplicate of this bug. ***

Comment 18 Jakub Hadvig 2020-01-29 13:32:04 UTC
*** Bug 1795738 has been marked as a duplicate of this bug. ***

Comment 20 paolo.frusone.wind 2020-02-12 13:49:43 UTC
Hi Vladislav,

we tried the strategy indicated by you but it still doesn't work. However, we have found a workaround which is to manually add the name of the configmap to be edited at the end of the configmap homepage link. In this way we are able to edit the CM from a WEB console (so we think it may be a simple problem of redirecting Hyperlinks).

Regards
Paolo

Comment 21 Vladislav Walek 2020-02-12 17:12:31 UTC
Hey Paolo,

that was for XiaochuanWang to test the behavior. Still checking update from Engineering about that.

Thx

Comment 23 errata-xmlrpc 2020-02-19 19:53:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0402

Comment 24 Takayoshi Kimura 2020-02-21 00:26:12 UTC
*** Bug 1804957 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.