Bug 1805 - relinked Oracle dumps core with glibc-2.1
Summary: relinked Oracle dumps core with glibc-2.1
Status: CLOSED DUPLICATE of bug 2187
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-26 02:24 UTC by Jaroslaw Sosnicki
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-16 15:30:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaroslaw Sosnicki 1999-03-26 02:24:23 UTC
There seems to be a major problem with relinking Oracle
8.0.5 and 8.0.5 EE on linux v2.2.x (intel) using
egcs-1.1.2 (glibc-2.1).

8.0.5 instals fine without relinking any of the
 executable and it works
8.0.5 EE forces relinking of all executables, relinking
works fine, when you execute any of the relinked files
it dumps core. Why?,

It looks as there is incompatibilities in the linked in
startup files.

When I relink Oracle with loader flag set to
"-nostartupfiles" I was able to run application but if
dumped core when I exit from exceuted application.

If you want to try it yourself, I used svrmgrl as an
example.

Any ideas on how to fix it?

Comment 1 Cristian Gafton 1999-06-16 15:30:59 UTC
*** This bug has been marked as a duplicate of 2187 ***


Note You need to log in before you can comment on or make changes to this bug.