Bug 2187 - glibc 2.1 and glibc 2.0.x compatibility module
glibc 2.1 and glibc 2.0.x compatibility module
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
: 1805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-15 00:09 EDT by Jaroslaw Sosnicki
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-16 11:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 1999-04-15 00:09:02 EDT
There seems to be a major problem with relinking Oracle
8.0.5 and 8.0.5 EE on linux v2.2.x (intel) using
egcs-1.1.2 (glibc-2.1).

Oracle RDBMS requires glibc 2.0.x where x is 6 or higher.

I think that you may want to look in to providing
compatibility library in addition to glibc 2.1 to allow
upward compatibility of apllications linked with glibc 2.0.x
the same way you do support libc5. If you don't you will
have software that no one will want to deal with in
production enviornment that needs to support Oracle RDBMS.

8.0.5 instals fine without relinking any of the
 executable and it works
8.0.5 EE forces relinking of all executables, relinking
works fine, when you execute any of the relinked files
it dumps core. Why?,

It looks as there is incompatibilities in the linked in
startup files.

When I relink Oracle with loader flag set to
"-nostartupfiles" I was able to run application but if
dumped core when I exit from exceuted application.

If you want to try it yourself, I used svrmgrl as an
example.

Any ideas on how to fix it?
Comment 1 Jaroslaw Sosnicki 1999-04-16 18:29:59 EDT
Is this problem be ever looked at?
Comment 2 Cristian Gafton 1999-06-16 11:10:59 EDT
afaik oracle is looking into this problem. Rh 6.0 shipped with a
number of compat-* packages. The Makefiles for relinking orcale will
have to be changed to use those compilers instead
(i386-glibc20-linux-gcc). For now, Oracle has to provide more details.
Comment 3 Cristian Gafton 1999-06-16 11:30:59 EDT
*** Bug 1805 has been marked as a duplicate of this bug. ***

There seems to be a major problem with relinking Oracle
8.0.5 and 8.0.5 EE on linux v2.2.x (intel) using
egcs-1.1.2 (glibc-2.1).

8.0.5 instals fine without relinking any of the
 executable and it works
8.0.5 EE forces relinking of all executables, relinking
works fine, when you execute any of the relinked files
it dumps core. Why?,

It looks as there is incompatibilities in the linked in
startup files.

When I relink Oracle with loader flag set to
"-nostartupfiles" I was able to run application but if
dumped core when I exit from exceuted application.

If you want to try it yourself, I used svrmgrl as an
example.

Any ideas on how to fix it?

Note You need to log in before you can comment on or make changes to this bug.