Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1805903 - Search page dropdown keyboard shortcuts don't work as expected
Summary: Search page dropdown keyboard shortcuts don't work as expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1806613
TreeView+ depends on / blocked
 
Reported: 2020-02-21 17:21 UTC by bmignano
Modified: 2020-07-13 17:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806613 (view as bug list)
Environment:
Version: 4.4.0-0.ci-2020-02-20-044240 Cluster ID: 223e19ec-0f8c-499c-9e99-dcb9fa4ed59f Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.116 Safari/537.36
Last Closed: 2020-07-13 17:16:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4490 0 None closed Bug 1805903: Fix tab order in dropdown list 2020-06-23 08:42:25 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:17:19 UTC

Description bmignano 2020-02-21 17:21:23 UTC
Description of problem: Tabbing through the dropdown on the search page works fine, but Enter only works to select an item if the row is highlighted as opposed to the checkbox.


Version-Release number of selected component (if applicable): 4.4


How reproducible: every time


Steps to Reproduce:
1. Open the dropdown
2. Tab through the items so a checkbox is in focus
3. Hit enter

Actual results: Nothing


Expected results: Item should be selected


Additional info:
It isn't necessary to tab through each checkbox and row since hitting Enter on either should do the same thing. Tab through either checkboxes or rows and allow users to select the item by hitting Enter.

Comment 4 Yanping Zhang 2020-03-03 11:19:36 UTC
Checked on ocp 4.5 cluster with payload 4.5.0-0.ci-2020-03-03-053944.
Steps to Reproduce:
1. Open the dropdown
2. Tab through the items so a item is highligted
3. Hit enter, the highlighted item is selected.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-07-13 17:16:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.