Bug 1806613 - Search page dropdown keyboard shortcuts don't work as expected
Summary: Search page dropdown keyboard shortcuts don't work as expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1805903
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 15:52 UTC by bpeterse
Modified: 2020-05-04 11:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1805903
Environment:
Version: 4.4.0-0.ci-2020-02-20-044240 Cluster ID: 223e19ec-0f8c-499c-9e99-dcb9fa4ed59f Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.116 Safari/537.36
Last Closed: 2020-05-04 11:39:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4522 0 None closed [release-4.4] Bug 1806613: Fix tab order in dropdown list 2020-04-29 17:54:32 UTC

Description bpeterse 2020-02-24 15:52:37 UTC
+++ This bug was initially created as a clone of Bug #1805903 +++

Description of problem: Tabbing through the dropdown on the search page works fine, but Enter only works to select an item if the row is highlighted as opposed to the checkbox.


Version-Release number of selected component (if applicable): 4.4


How reproducible: every time


Steps to Reproduce:
1. Open the dropdown
2. Tab through the items so a checkbox is in focus
3. Hit enter

Actual results: Nothing


Expected results: Item should be selected


Additional info:
It isn't necessary to tab through each checkbox and row since hitting Enter on either should do the same thing. Tab through either checkboxes or rows and allow users to select the item by hitting Enter.

Comment 4 Yanping Zhang 2020-03-03 07:31:00 UTC
Tested on OCP 4.4 env with payload 4.4.0-0.nightly-2020-03-02-231151. Go to "Search" page, in the dropdown list, tab between items, item will be highlighted, press enter, the highlighted item will be selected.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-05-04 11:39:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.