Bug 180599 - Netgear ma401 wireless card no longer operates after upgrading kernel to 2.6.15 using yum on 2/7/06
Netgear ma401 wireless card no longer operates after upgrading kernel to 2.6....
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 03:32 EST by Bob E
Modified: 2008-01-19 23:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:41:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob E 2006-02-09 03:32:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
Wireless networking worked before I updated using yum on 2/7/06.

Hardware:

Netgear MA401 Wireless card
Dell Inspiron 8200 laptop


Here's what was updated:

Feb 07 23:05:32 Updated: enchant.i386 1:1.2.2-1.fc4
Feb 07 23:05:33 Updated: cups-libs.i386 1:1.1.23-15.4
Feb 07 23:05:36 Updated: arts.i386 8:1.5.1-0.1.fc4
Feb 07 23:05:37 Updated: audit-libs.i386 1.0.13-1.fc4
Feb 07 23:05:39 Updated: module-init-tools.i386 3.2-0.pre9.0.FC4.1
Feb 07 23:05:51 Updated: cups.i386 1:1.1.23-15.4
Feb 07 23:08:28 Installed: kernel-devel.i686 2.6.15-1.1831_FC4
Feb 07 23:08:40 Updated: abiword.i386 1:2.4.2-2.fc4
Feb 07 23:08:44 Updated: udev.i386 071-0.FC4.2
Feb 07 23:08:45 Updated: audit.i386 1.0.13-1.fc4
Feb 07 23:08:46 Updated: unzip.i386 5.51-13.fc4
Feb 07 23:09:19 Installed: kernel.i686 2.6.15-1.1831_FC4
Feb 07 23:09:21 Updated: autofs.i386 1:4.1.4-15.1

Using graphical system-network-configure I can no longer see an entry for the Netgear MA401 wireless card. I erased the entry to try reinstalling it, but could no longer see the orinoco entry as a wireless card selection. 

Here's some dmesg output that might indicate there are problems configuring and initializing the wireless card:

hostap_cs: 0.4.4-kernel (Jouni Malinen <jkmaline@cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: Registered netdevice wifi0
wifi0: Interrupt, but dev not OK
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0xe100-0xe13f
orinoco 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
orinoco_cs 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
prism2_hw_init: initialized in 220 ms
wifi0: NIC: id=0x800c v1.0.0
wifi0: PRI: id=0x15 v1.0.7
wifi0: STA: id=0x1f v1.3.6
wifi0: defaulting to host-based encryption as a workaround for firmware bug in Host AP mode WEP
wifi0: defaulting to bogus WDS frame as a workaround for firmware bug in Host AP mode WDS
wifi0: registered netdevice wlan0
pcmcia: registering new device pcmcia1.1
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: setting Vcc=2 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
  Vcc mismatch - skipping this entry
1.1: GetNextTuple: No more items
prism2_config() failed

Thank you

Version-Release number of selected component (if applicable):
kernel 2.6.15-1.1831_FC4

How reproducible:
Always

Steps to Reproduce:
1.Boot system
2.Initialization gets to PCMCIA module load
3.The link LED on the wireless card begins blinking after the PCMCIA says it is watching two sockets.
  

Additional info:
Comment 1 Bob E 2006-02-10 00:18:46 EST
I got wireless networking to work by:

Backed up /lib/modules/2.6.15-1.1831_FC4/kernel/drivers/net/wireless/hostaps/*
to hostaps/temp/

Copied hostaps/* from previous kernel (2.6.14-1.1656_FC4) to:
/lib/modules/2.6.15-1.1831_FC4/kernel/drivers/net/wireless/hostaps

Executed GUI system-config-network and was able to see the driver entry for
Netgear MA401. Reset the wireless details and activated the entry.

Don't know if this is a healthy fix but it hasn't blown up yet. Yay!
Comment 2 Dave Jones 2006-09-16 23:22:23 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 3 Bob E 2006-09-17 22:59:20 EDT
Switched to FC5 and had no further wireless problems. Can not remember how I
worked around problem in FC4. Moving right along. Thanks.
Comment 4 Dave Jones 2006-10-16 15:45:33 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Jon Stanley 2008-01-19 23:41:43 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.