Bug 1806114 - Issue with typing custom query in promQl editor in metrics tab
Summary: Issue with typing custom query in promQl editor in metrics tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1806799
TreeView+ depends on / blocked
 
Reported: 2020-02-22 08:26 UTC by Jaivardhan Kumar
Modified: 2020-08-04 18:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Issue with typing custom query in promQl editor in metrics tab as Redux store was getting updated on each keypress and component as well was relying on it being a connected component Consequence: An issue with typing custom query in promQl editor in metrics tab i.e if you start editing in between existing query cursor moves to the line end. Fix: Made use of hook useSelector to bring redux into the same render function and avoid using a HOC Result: Typing in custom query in promQl editor in metrics tab works as expected
Clone Of:
: 1806799 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:01:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
No Issue with typing custom query in promQl editor in metrics tab (198.13 KB, video/webm)
2020-02-25 22:27 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4426 None closed Bug 1806114: fixes issue with editing customQueries in promQL 2020-06-30 17:26:48 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:01:44 UTC

Description Jaivardhan Kumar 2020-02-22 08:26:03 UTC
Description of problem: Issue with typing custom query in promQl editor in metrics tab of devConsole monitoring


Version-Release number of selected component (if applicable):4.4


How reproducible: Always


Steps to Reproduce:
1. Go to DevConsole -> Monitoring  -> metrics tab
2. Select CustomQuery
3. Type some Query and try editing it

Actual results: User should be able to edit queries with ease


Expected results: if the user starts editing in between the existing query cursor moves to the line end.


Additional info:

Comment 1 spathak@redhat.com 2020-02-25 22:27:32 UTC
Created attachment 1665743 [details]
No Issue with typing custom query in promQl editor in metrics tab

Comment 2 spathak@redhat.com 2020-02-25 22:31:15 UTC
Verified on build : 4.5.0-0.ci-2020-02-25-152421
Chrome browser: 76.0.3809.132

Comment 5 errata-xmlrpc 2020-08-04 18:01:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.