Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806799 - Issue with typing custom query in promQl editor in metrics tab
Summary: Issue with typing custom query in promQl editor in metrics tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1806114
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 04:12 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Issue with typing custom query in promQl editor in metrics tab as Redux store was getting updated on each keypress and component as well was relying on it being a connected component Consequence: An issue with typing custom query in promQl editor in metrics tab i.e if you start editing in between existing query cursor moves to the line end. Fix: Made use of hook useSelector to bring redux into the same render function and avoid using a HOC Result: Typing in custom query in promQl editor in metrics tab works as expected
Clone Of: 1806114
Environment:
Last Closed: 2020-05-04 11:39:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
No issue with typing custom query in promQl editor in metrics tab (164.70 KB, video/webm)
2020-02-27 10:37 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4452 0 None closed [release-4.4] Bug 1806799: fixes issue with editing customQueries in promQL 2020-04-20 11:44:03 UTC

Description Jaivardhan Kumar 2020-02-25 04:12:13 UTC
+++ This bug was initially created as a clone of Bug #1806114 +++

Description of problem: Issue with typing custom query in promQl editor in metrics tab of devConsole monitoring


Version-Release number of selected component (if applicable):4.4


How reproducible: Always


Steps to Reproduce:
1. Go to DevConsole -> Monitoring  -> metrics tab
2. Select CustomQuery
3. Type some Query and try editing it

Actual results: User should be able to edit queries with ease


Expected results: if the user starts editing in between the existing query cursor moves to the line end.


Additional info:

Comment 3 spathak@redhat.com 2020-02-27 10:37:59 UTC
Created attachment 1666171 [details]
No issue with typing custom query in promQl editor in metrics tab

Comment 4 spathak@redhat.com 2020-02-27 10:39:34 UTC
Verified on build : 4.4.0-0.ci-2020-02-26-215902
Chrome browser: 76.0.3809.132

Comment 6 errata-xmlrpc 2020-05-04 11:39:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.