Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806155 - OperatorHub can have duplicate items when 'all projects' is selected, which also breaks filtering
Summary: OperatorHub can have duplicate items when 'all projects' is selected, which a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1805994
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-22 13:24 UTC by Samuel Padgett
Modified: 2020-05-04 11:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1805994
Environment:
Last Closed: 2020-05-04 11:39:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4427 0 None open [release-4.4] Bug 1806155: Remove duplicate entries on operator hub page 2020-02-22 13:25:31 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:39:28 UTC

Description Samuel Padgett 2020-02-22 13:24:09 UTC
+++ This bug was initially created as a clone of Bug #1805994 +++

This bug was initially created as a copy of Bug #1799463

I am copying this bug because: 

We should tolerate duplicates in console even if they're not expected.

Description of problem:

Selecting 'all-projects' on the OperatorHub page causes the operator items on the page to be duplicated and breaks the filtering functionality.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always under the correct conditions

Steps to Reproduce:
1. Use a 4.4 cluster and ensure the following default sources are available and enabled:
   - redhat-operators
   - certified-operators
   - community-operators
   - redhat-marketplace 
2. Navigate to Operators > OperatorHub
3. Select 'default' from the projects dropdown
4. Note the item count
5. Enter 'test' in the keyword filter
6. Note the filtered item count
7. Select 'all projects' from the projects dropdown
8. Enter 'test' in the keyword filter

Actual results:
Item count is doubled both before and after the filter term is entered and duplicate items are being displayed on the page. Item count also does not match the number of items displayed on the page.

Expected results:
Duplicate items should not be displayed and item count should match the number of items displayed.

Additional info:
Suspect that packageManifest and marketPlacePackageManifest props retreived by firehose component contain overlapping results depending on what catalog sources are available and what namespace is selected. Probably need to either add a special case when all projects is selected, adjust our selectors to ensure no overlap, or add some logic after the call to reduce the package manifest props to a single unique list.

Comment 3 XiaochuanWang 2020-02-24 06:08:14 UTC
Follow the description, filtered items are listed correctly without dup.
Verified on 4.4.0-0.nightly-2020-02-23-191320

Comment 5 errata-xmlrpc 2020-05-04 11:39:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.