Bug 1806334 - No audio after upgrade to kernel 5.5.5
Summary: No audio after upgrade to kernel 5.5.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-23 21:54 UTC by Serge Matveenko
Modified: 2020-05-02 12:38 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-02 12:38:58 UTC
Type: Bug


Attachments (Terms of Use)
journalctl --no-hostname -k > dmesg.txt (100.94 KB, text/plain)
2020-02-23 22:02 UTC, Serge Matveenko
no flags Details
pacmd list-sources > pa-sources.txt (9.38 KB, text/plain)
2020-02-24 19:17 UTC, Serge Matveenko
no flags Details
pacmd list-sinks > pa-sinks.txt (9.97 KB, text/plain)
2020-02-26 11:37 UTC, Serge Matveenko
no flags Details
sudo alsa-info.sh --no-upload > alsa-info.txt (60 bytes, text/plain)
2020-02-26 11:38 UTC, Serge Matveenko
no flags Details
pacmd list-sinks > pa-sinks.txt (7.89 KB, text/plain)
2020-02-26 19:17 UTC, Serge Matveenko
no flags Details
alsa-info.sh --no-upload (32.67 KB, text/plain)
2020-02-26 19:18 UTC, Serge Matveenko
no flags Details
journalctl --no-hostname --boot=67 > dmesg-5.5.6.txt (161.74 KB, text/plain)
2020-02-27 11:29 UTC, Serge Matveenko
no flags Details
journalctl --no-hostname --boot=71 > dmesg-5.5.6-201.txt (180.27 KB, text/plain)
2020-02-29 22:28 UTC, Serge Matveenko
no flags Details
Random commands and their output (3.22 KB, text/plain)
2020-04-28 16:11 UTC, Andre Klapper
no flags Details

Description Serge Matveenko 2020-02-23 21:54:52 UTC
1. Please describe the problem:

No audio on kernel 5.5.5.

I'm using Fedora 31. I've just upgraded the system. Audio is not working. Pulseaudio shows only dummy output.

Rebooted to the previous kernel. Everything works as expected.

Soundcard: 00:1f.3 Multimedia audio controller: Intel Corporation Device 02c8
Works on: 5.4.20-200.fc31.x86_64
Doesn't work on: 5.5.5-200.fc31.x86_64


2. What is the Version-Release number of the kernel:

5.5.5-200.fc31.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Audio works on the same system with kernel 5.4.20-200.fc31.x86_64


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

* Upgrade Fedora 31 to have the latest kernel 5.5.5 installed.
* Reboot with the default kernel.


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

N/A


6. Are you running any modules that not shipped with directly Fedora's kernel?:

Yes. Nvidia proprietary driver from rpmfusion.


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Will do.

Comment 1 Serge Matveenko 2020-02-23 22:02:42 UTC
Created attachment 1665258 [details]
journalctl --no-hostname -k > dmesg.txt

Comment 2 Serge Matveenko 2020-02-23 22:03:58 UTC
> cat dmesg.txt | grep -i audio
фев 24 00:55:37 kernel: ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: enabling device (0000 -> 0002)
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: warning: No matching ASoC machine driver found
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: use msi interrupt mode
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cml.ri failed with error -2
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cml.ri failed err: -2
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
фев 24 00:55:47 kernel: sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2

Comment 3 Jaroslav Kysela 2020-02-24 18:35:15 UTC
Install alsa-firmware package... Does it help?

Comment 4 Jaroslav Kysela 2020-02-24 18:39:42 UTC
See the bug #1772498 what components should be installed for your hardware to enable the internal microphone.

Comment 5 Serge Matveenko 2020-02-24 18:58:51 UTC
(In reply to Jaroslav Kysela from comment #3)
> Install alsa-firmware package... Does it help?

Yes. After installing alsa-firmware and rebooting the audio device is operational as sof-hda-dsp device.

Thanks. It looks like alsa-firmware should be installed with fedora-workstation if there is no way to tell the user to install it if such a device is present.

Comment 6 Serge Matveenko 2020-02-24 19:17:10 UTC
(In reply to Jaroslav Kysela from comment #3)
> Install alsa-firmware package... Does it help?

Still no sound. Pulseaudio reports sources as suspended. Applications (aplay, celluloid) hang when trying to playback sound then run with no sound.

Attaching `pacmd list-sources` output.

Comment 7 Serge Matveenko 2020-02-24 19:17:55 UTC
Created attachment 1665491 [details]
pacmd list-sources > pa-sources.txt

Comment 8 Jaroslav Kysela 2020-02-24 19:27:25 UTC
Please, show sinks (list-sinks) to see the output ports. Attach also output from 'alsa-info.sh --no-upload'. Thanks.

Comment 9 Serge Matveenko 2020-02-26 11:37:13 UTC
↪ sudo alsa-info.sh --no-upload > alsa-info.txt
cat: '/sys/module/snd_soc_skl_hda_dsp/parameters/*': No such file or directory

Comment 10 Serge Matveenko 2020-02-26 11:37:58 UTC
Created attachment 1665912 [details]
pacmd list-sinks > pa-sinks.txt

Comment 11 Serge Matveenko 2020-02-26 11:38:21 UTC
Created attachment 1665913 [details]
sudo alsa-info.sh --no-upload > alsa-info.txt

Comment 12 Serge Matveenko 2020-02-26 19:17:32 UTC
Created attachment 1666066 [details]
pacmd list-sinks > pa-sinks.txt

Comment 13 Serge Matveenko 2020-02-26 19:18:21 UTC
Created attachment 1666067 [details]
alsa-info.sh --no-upload

Comment 14 Serge Matveenko 2020-02-26 19:25:04 UTC
After boot, it looks like headphone output is being used. Changing volume in gnome shows "Headphones". `aplay` reports that it plays something. Choosing Speaker output in the Gnome sound output extension takes several seconds and after that aplay hangs on launch.

Comment 15 Jaroslav Kysela 2020-02-26 23:18:50 UTC
Use kernel-5.5.5-200.sof1.fc31 kernel from  bug #1772498 .

Comment 16 Serge Matveenko 2020-02-27 08:02:41 UTC
Everythings works with kernel-5.5.5-200.sof1.fc31 except aplay plays noise instead of sounds. All other applications seem to work and play sound properly. Mics work as well. I don't know whether aplay worked with 5.4.20 kernel. Will check later.

Comment 17 Jaroslav Kysela 2020-02-27 08:16:39 UTC
Thanks. Could you also check 5.5.6 kernel? https://bodhi.fedoraproject.org/updates/FEDORA-2020-3cd64d683c

Comment 18 Serge Matveenko 2020-02-27 10:47:34 UTC
(In reply to Jaroslav Kysela from comment #17)
> Thanks. Could you also check 5.5.6 kernel?
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-3cd64d683c

There are only kernel, kernel-headers, and kernel-tools packages available in the Builds section. Is it enough to test? I'm concerned that there are no usual kernel-core, kernel-devel, and kernel-modules{,-extra} packages.

Comment 19 Jaroslav Kysela 2020-02-27 10:52:40 UTC
If you click on the kernel, you'll see all packages for all archs: https://koji.fedoraproject.org/koji/buildinfo?buildID=1470026

Comment 20 Serge Matveenko 2020-02-27 11:28:57 UTC
With 5.5.6 system cannot boot. Hangs on udev device initialization job. Attaching dmesg.

Comment 21 Serge Matveenko 2020-02-27 11:29:51 UTC
Created attachment 1666179 [details]
journalctl --no-hostname --boot=67 > dmesg-5.5.6.txt

Comment 22 Serge Matveenko 2020-02-29 22:27:54 UTC
I just got kernel 5.5.6-201.fc31 from the updates via dnf upgrade.

The system still cannot boot with this one.

Attaching dmesg.

Should I report another bug maybe?

Comment 23 Serge Matveenko 2020-02-29 22:28:31 UTC
Created attachment 1666661 [details]
journalctl --no-hostname --boot=71 > dmesg-5.5.6-201.txt

Comment 24 Jaroslav Kysela 2020-03-01 07:45:38 UTC
Please, upgrade to 5.5.7. This bug was fixed there.

Comment 25 Sander Vermin 2020-03-01 10:30:27 UTC
For me the 5.5.7 kernel still has no sound, I found this in my dmesg:

[   12.964387] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[   12.964633] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[   13.059801] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[   13.060669] sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[   13.060690] sof-audio-pci 0000:00:1f.3: enabling device (0000 -> 0002)
[   13.061346] sof-audio-pci 0000:00:1f.3: warning: No matching ASoC machine driver found
[   13.061375] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
[   13.061847] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   13.066692] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[   13.071177] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[   13.071184] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[   13.151730] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cnl.ri failed with error -2
[   13.151740] sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cnl.ri failed err: -2
[   13.151744] sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
[   13.153007] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2

Comment 26 itblaked 2020-03-01 11:13:03 UTC
I had the same boot failure with 5.5.6 so updated to latest rawhide kernel-5.6.0-0.rc3.git2.1.fc33.x86_64. I've created bug #1808784 https://bugzilla.redhat.com/show_bug.cgi?id=1808784 for the boot issue and linked to this.

I'm running F31 on a Lenovo X1 Carbon Gen7.

On the new kernel the audio is detected fine, however not the microphone, only difference I could spot was (Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: Firmware info: version 1:1:0-fcf6c):

ar 01 20:04:31 kernel: usbcore: registered new interface driver snd-usb-audio
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: use msi interrupt mode
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: unexpected ipc interrupt raised!
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: Firmware info: version 1:1:0-fcf6c
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:11:0 Kernel ABI 3:12:0
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: Topology: ABI 3:11:0 Kernel ABI 3:12:0
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp3 Tx not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec0_in not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp2 Tx not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec1_in not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp1 Tx not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec0_out not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Analog CPU Playback not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec1_out not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Digital CPU Playback not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec2_in not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Alt Analog CPU Playback not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec2_out not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Analog CPU Capture not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp1_out not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Digital CPU Capture not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp2_out not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Alt Analog CPU Capture not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp3_out not handled
Mar 01 20:04:32 kernel: sof-audio-pci 0000:00:1f.3: ASoC: Parent card not yet available, widget card binding deferred
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0: autoconfig for ALC285: line_outs=2 (0x14/0x17/0x0/0x0/0x0) type:speaker
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0:    mono: mono_out=0x0
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0:    inputs:
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0:      Mic=0x19
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0: ASoC: sink widget AIF1TX overwritten
Mar 01 20:04:32 kernel: snd_hda_codec_realtek ehdaudio0D0: ASoC: source widget AIF1RX overwritten
Mar 01 20:04:35 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 20:04:36 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 20:04:54 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 20:04:54 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete


I also updated alsa-firmware from rawhide and mics are now working good, boot log grep audio post alsa upgrade (Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: Firmware info: version 1:4:2-66a5a):

Mar 01 20:22:33 kernel: usbcore: registered new interface driver snd-usb-audio
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: use msi interrupt mode
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: unexpected ipc interrupt raised!
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: Firmware info: version 1:4:2-66a5a
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:11:0 Kernel ABI 3:12:0
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: Topology: ABI 3:11:0 Kernel ABI 3:12:0
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp3 Tx not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec0_in not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp2 Tx not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec1_in not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name iDisp1 Tx not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec0_out not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Analog CPU Playback not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec1_out not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Digital CPU Playback not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name codec2_in not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 7 name Alt Analog CPU Playback not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name codec2_out not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Analog CPU Capture not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp1_out not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Digital CPU Capture not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp2_out not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 0 name Alt Analog CPU Capture not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: warning: widget type 1 name iDisp3_out not handled
Mar 01 20:22:34 kernel: sof-audio-pci 0000:00:1f.3: ASoC: Parent card not yet available, widget card binding deferred
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0: autoconfig for ALC285: line_outs=2 (0x14/0x17/0x0/0x0/0x0) type:speaker
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0:    mono: mono_out=0x0
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0:    inputs:
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0:      Mic=0x19
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0: ASoC: sink widget AIF1TX overwritten
Mar 01 20:22:34 kernel: snd_hda_codec_realtek ehdaudio0D0: ASoC: source widget AIF1RX overwritten
Mar 01 20:22:37 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 20:22:37 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 20:41:57 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 20:41:57 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 21:59:46 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 21:59:46 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 22:01:42 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 22:01:42 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Mar 01 22:04:50 kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Mar 01 22:04:50 kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete

Comment 27 Jaroslav Kysela 2020-03-01 12:25:14 UTC
(In reply to Sander Vermin from comment #25)
> For me the 5.5.7 kernel still has no sound, I found this in my dmesg:

> [   13.151740] sof-audio-pci 0000:00:1f.3: error: request firmware
> intel/sof/sof-cnl.ri failed err: -2

Install alsa-firmware and pulseaudio package.

(In reply to itblaked from comment #26)
> I had the same boot failure with 5.5.6 so updated to latest rawhide
> kernel-5.6.0-0.rc3.git2.1.fc33.x86_64. I've created bug #1808784
> https://bugzilla.redhat.com/show_bug.cgi?id=1808784 for the boot issue and
> linked to this.
> 
> I'm running F31 on a Lenovo X1 Carbon Gen7.
> 
> On the new kernel the audio is detected fine, however not the microphone,

Install latest pulseaudio.

Comment 28 itblaked 2020-03-01 19:40:27 UTC
(In reply to Jaroslav Kysela from comment #27)
> (In reply to Sander Vermin from comment #25)
> > For me the 5.5.7 kernel still has no sound, I found this in my dmesg:
> 
> > [   13.151740] sof-audio-pci 0000:00:1f.3: error: request firmware
> > intel/sof/sof-cnl.ri failed err: -2
> 
> Install alsa-firmware and pulseaudio package.
> 
> (In reply to itblaked from comment #26)
> > I had the same boot failure with 5.5.6 so updated to latest rawhide
> > kernel-5.6.0-0.rc3.git2.1.fc33.x86_64. I've created bug #1808784
> > https://bugzilla.redhat.com/show_bug.cgi?id=1808784 for the boot issue and
> > linked to this.
> > 
> > I'm running F31 on a Lenovo X1 Carbon Gen7.
> > 
> > On the new kernel the audio is detected fine, however not the microphone,
> 
> Install latest pulseaudio.

The latest alsa-firmware from rawhide fixed it, no need to update pulseaudio

Comment 29 itblaked 2020-03-01 20:15:17 UTC
I installed kernel 5.5.7 with alsa-firmware from latest-testing repo and microphone/speaker both working successfully.

Comment 30 Serge Matveenko 2020-03-01 20:31:32 UTC
kernel 5.5.7 https://koji.fedoraproject.org/koji/buildinfo?buildID=1472109
pulseaudio-13.0-2.fc31.x86_64 
alsa-firmware-1.2.1-4.fc31.noarch

Everything works but pulseaudio could become unresponsive after mic volume being changed (reproduced only once, wasn't able to reproduce again). After `pulseaudio -k` works fine. Sound and mic work.

Jaroslav, thanks for fixing this.

Comment 31 Andre Klapper 2020-04-28 16:11:18 UTC
Created attachment 1682546 [details]
Random commands and their output

I am still facing this problem in Fedora 32 on a ThinkPad X1 Carbon 7th with:
* pulseaudio-13.99.1-3.fc32.x86_64
* alsa-firmware-1.2.1-7.fc32.noarch
* kernel-5.6.7-300.fc32.x86_64

I successfully made audio output work by passing "snd_hda_intel.dmic_detect=0" as a boot option (found that in Arch Linux task 64720). 
Still no audio input device found though.

Comment 32 mechonbarsa@gmail.com 2020-04-28 22:35:34 UTC
I have the same issue as Andre. Just upgraded to Fedora 32 on my Lenovo Yoga S740. Applied the snd_hda_intel.dmic_detect=0 workaround as a boot option and sound came back.

It should be pointed out that this problem was in alsa-firmware, and I tested a package in testing and it worked about 3 months ago. Check this: https://bodhi.fedoraproject.org/updates/FEDORA-2020-534cccb6cb

Comment 33 Hans de Goede 2020-04-29 09:22:29 UTC
Andre, Mechon,

The SOF firmware has been split of from the main alsa-firmware package. So you need alsa-sof-firmware. New Fedora 32 installs will add this automatically, but it looks like we still have an issue where it does not get automatically installed on upgrades.

Can you try doing:

sudo dnf install alsa-sof-firmware

And if that indeed installs a new package, then try dropping the "snd_hda_intel.dmic_detect=0" boot option and also revert any other config changes you have done. At least on the ThinkPad X1 Carbon 7t everything should work fine (get sound of all 4 speakers instead of only 2, working mic). I don't know what the status is on the Lenovo Yoga S740.

Comment 34 Andre Klapper 2020-04-29 09:40:43 UTC
Thanks Hans! I can confirm that both audio input and output work as expected after manually installing the package alsa-sof-firmware.

Comment 35 Hans de Goede 2020-04-29 10:00:21 UTC
(In reply to Andre Klapper from comment #34)
> Thanks Hans! I can confirm that both audio input and output work as expected
> after manually installing the package alsa-sof-firmware.

Great. So for new F32 installs the package should be there. For upgrades the plan was to have the F31 kernel-modules package depend on alsa-sof-firmware and since people should fully upgrade F31, before doing the F32 upgrade, that should have taken care of this. But the Requires on alsa-sof-firmware is not yet present in the F31 kernel-modules packages...

I'm working on fixing this now.

Comment 36 mechonbarsa@gmail.com 2020-04-29 17:44:05 UTC
Hans, I did the following steps on my Lenovo Yoga S740 (Fedora 32):

- Installed alsa-sof-firmware-1.4.2-4.fc32.noarch
- Rebooted without the "snd_hda_intel.dmic_detect=0" workaround. No sound.
- Rebooted again, and added the workaround, and started working.

Comment 37 Hans de Goede 2020-04-30 09:35:40 UTC
(In reply to mechonbarsa@gmail.com from comment #36)
> Hans, I did the following steps on my Lenovo Yoga S740 (Fedora 32):
> 
> - Installed alsa-sof-firmware-1.4.2-4.fc32.noarch
> - Rebooted without the "snd_hda_intel.dmic_detect=0" workaround. No sound.
> - Rebooted again, and added the workaround, and started working.

Ok, so it looks like your laptop still needs some more work for SOF audio to work properly on it. Can you please file a new bug for this against alsa-lib (kernel bugs can be about anything, this way the bug will get assigned to the sound maintainers)?

Comment 38 Jaroslav Kysela 2020-04-30 14:05:21 UTC
Please, attach also 'alsa-info.sh --no-upload' to the new bug for the further analysis.

Comment 39 mechonbarsa@gmail.com 2020-04-30 14:58:48 UTC
Thanks for the advice. Bug #1829917 is open.

Comment 40 Andre Klapper 2020-05-02 08:01:03 UTC
Installing "kernel 5.6.8-300.fc32" listed "Installing weak dependencies: alsa-sof-firmware 1.4.2-4.fc32". I think this ticket could get closed?

Comment 41 Hans de Goede 2020-05-02 12:38:58 UTC
(In reply to Andre Klapper from comment #40)
> Installing "kernel 5.6.8-300.fc32" listed "Installing weak dependencies:
> alsa-sof-firmware 1.4.2-4.fc32". I think this ticket could get closed?

Yes this can be closed now. I'll close it right away.


Note You need to log in before you can comment on or make changes to this bug.