Bug 1829917 - No sound (SOF)
Summary: No sound (SOF)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-sof-firmware
Version: 32
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1829388 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 14:57 UTC by mechonbarsa@gmail.com
Modified: 2020-10-07 20:08 UTC (History)
6 users (show)

Fixed In Version: alsa-sof-firmware-1.4.2-5.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-06 04:29:54 UTC
Type: Bug


Attachments (Terms of Use)
alsa-info output (7.78 KB, text/plain)
2020-04-30 14:57 UTC, mechonbarsa@gmail.com
no flags Details
symlink (98.47 KB, image/png)
2020-04-30 15:19 UTC, mechonbarsa@gmail.com
no flags Details
symlink-created (117.41 KB, image/png)
2020-04-30 15:51 UTC, mechonbarsa@gmail.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1806334 unspecified CLOSED No audio after upgrade to kernel 5.5.5 2020-10-14 00:28:05 UTC

Description mechonbarsa@gmail.com 2020-04-30 14:57:51 UTC
Created attachment 1683331 [details]
alsa-info output

Description of problem:

After Fedora 31 to 32 upgrade, no sound outputs are detected, and I have no sound at all.

Version-Release number of selected component (if applicable):

* alsa-sof-firmware-1.4.2-4.fc32.noarch
* alsa-lib-1.2.2-2.fc32.x86_64

How reproducible:

This happens in a Lenovo Yoga S740 with Fedora 32 (64-bit).

Steps to Reproduce:
1. Turn on the equipment. No sound at all.
2. Reboot and edit kernel boot options to add "snd_hda_intel.dmic_detect=0"
3. Start the system and sound finally works.

Actual results:

No sound except when applied the "snd_hda_intel.dmic_detect=0" workaround.

Expected results:

Sound working.

Additional info:

This has happened before in Fedora 31, and was fixed in this Bodhi issue: https://bodhi.fedoraproject.org/updates/FEDORA-2020-534cccb6cb. As adviced, I'm adding the alsa-info.sh --no-upload output as an attachment.

Comment 1 Jaroslav Kysela 2020-04-30 15:02:33 UTC
Here is the problem:

[   23.330222] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[   23.330223] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[   23.331010] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cfl.ri failed with error -2

Could you try to create symlink to v1.4.2/intel-signed/sof-cnl-v1.4.2.ri like sof-cml.ri ? In the /lib/firmware/intel/sof directory. Reboot then.

Comment 2 mechonbarsa@gmail.com 2020-04-30 15:19:24 UTC
Created attachment 1683337 [details]
symlink

Jaroslav,

The symlink you asked me to create is already there. In fact, there are two different symlinks (sof-cml.ri, sof-cnl.ri) pointing to v1.4.2/intel-signed/sof-cnl-v1.4.2.ri.

Comment 3 Jaroslav Kysela 2020-04-30 15:41:18 UTC
I know, but the kernel requires sof-cfl.ri file. Please, create 'sof-cfl.ri -> v1.4.2/intel-signed/sof-cnl-v1.4.2.ri' symlink.

Comment 4 mechonbarsa@gmail.com 2020-04-30 15:51:50 UTC
Created attachment 1683339 [details]
symlink-created

Jaroslav,

I created the symlink, rebooted and sound is back online. What are the next steps? Do I leave the symlink there? Remove it and wait for a patch?

Comment 5 Fedora Update System 2020-04-30 16:15:53 UTC
FEDORA-2020-22efdc96d1 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-22efdc96d1

Comment 6 Jaroslav Kysela 2020-04-30 16:16:31 UTC
Could you test above update ?

Comment 7 mechonbarsa@gmail.com 2020-04-30 16:27:10 UTC
Yes. I will remove the symlink first, reboot and install the update

Comment 8 mechonbarsa@gmail.com 2020-04-30 16:41:03 UTC
Done, works OK. Thank you very much.

Comment 9 Fedora Update System 2020-05-01 19:22:27 UTC
FEDORA-2020-22efdc96d1 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-22efdc96d1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-22efdc96d1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Egor Susloparov 2020-05-02 17:28:55 UTC
*** Bug 1829388 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2020-05-06 04:29:54 UTC
FEDORA-2020-22efdc96d1 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Miroslav Krýsl 2020-10-07 20:08:57 UTC
Hello,
Today I have installed Fedora 33 Beta on Lenovo s740 with Intel Core i7-9750H
and I do not have sound output from speakers.
May it be caused by the sof-firmware bug?

Installed sof version:
alsa-sof-firmware-1.5-2.fc33.noarch

Built-in microphone and any external audio devices works normally
except the built-in speakers.

I have tried set the kernel parameter
snd_hda_intel.dmic_detect=0
but then stopped working even the microphone.

I will try to install F32 but according to this bug report
it already should be fixed on F32.


Note You need to log in before you can comment on or make changes to this bug.