Bug 1806615 - Installed Operators: Runtime error viewing packageserver
Summary: Installed Operators: Runtime error viewing packageserver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1806617
TreeView+ depends on / blocked
 
Reported: 2020-02-24 15:56 UTC by Samuel Padgett
Modified: 2020-07-13 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806617 (view as bug list)
Environment:
Version: 4.5.0-0.ci-2020-02-24-112808 Cluster ID: 92fc0c6b-bcdd-4c39-a547-e32e250de6d8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0
Last Closed: 2020-07-13 17:20:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error page (83.45 KB, image/png)
2020-02-24 15:56 UTC, Samuel Padgett
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4441 0 None closed Bug 1806615: Fix runtime error when CSV has no annotations 2020-06-23 08:46:01 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:02 UTC

Description Samuel Padgett 2020-02-24 15:56:53 UTC
Created attachment 1665472 [details]
Error page

Steps to reproduce:

1. Select all projects
2. Go to Operators -> Installed Operators
3. Select packageserver

You see a runtime error:

TypeError: "metadata.annotations is undefined"
    ClusterServiceVersionDetails clusterserviceversion.tsx:608
    React 17
    Redux 7
    watchK8sObject/</WS[id]</< k8s.ts:113
    watchK8sObject/</WS[id]< k8s.ts:113
    _invokeHandlers ws-factory.js:141
    _invokeHandlers ws-factory.js:139
    flushMessageBuffer

Comment 3 Yanping Zhang 2020-03-04 04:02:53 UTC
Checked on 4.5 cluster with payload 4.5.0-0.ci-2020-03-03-053944.
Steps to verify:
1. Select all projects
2. Go to Operators -> Installed Operators
3. Select packageserver, there is not runtime error now.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-07-13 17:20:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.