Bug 1806617 - Installed Operators: Runtime error viewing packageserver
Summary: Installed Operators: Runtime error viewing packageserver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: shahan
URL:
Whiteboard:
Depends On: 1806615
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 16:02 UTC by Samuel Padgett
Modified: 2020-05-04 11:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1806615
Environment:
Version: 4.5.0-0.ci-2020-02-24-112808 Cluster ID: 92fc0c6b-bcdd-4c39-a547-e32e250de6d8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:73.0) Gecko/20100101 Firefox/73.0
Last Closed: 2020-05-04 11:39:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4447 0 None closed [release-4.4] Bug 1806617: Fix runtime error when CSV has no annotations 2020-04-17 17:59:22 UTC

Description Samuel Padgett 2020-02-24 16:02:26 UTC
+++ This bug was initially created as a clone of Bug #1806615 +++

Steps to reproduce:

1. Select all projects
2. Go to Operators -> Installed Operators
3. Select packageserver

You see a runtime error:

TypeError: "metadata.annotations is undefined"
    ClusterServiceVersionDetails clusterserviceversion.tsx:608
    React 17
    Redux 7
    watchK8sObject/</WS[id]</< k8s.ts:113
    watchK8sObject/</WS[id]< k8s.ts:113
    _invokeHandlers ws-factory.js:141
    _invokeHandlers ws-factory.js:139
    flushMessageBuffer

Comment 3 shahan 2020-02-27 09:28:06 UTC
1. Select all projects
2. Go to Operators -> Installed Operators
3. Select packageserver
 did not see the runtime error.
4.4.0-0.nightly-2020-02-26-060047

Comment 6 errata-xmlrpc 2020-05-04 11:39:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.