Bug 1806675 - [ESXi][RHEL7.9]Rebase open-vm-tools to 11.0.5 for RHEL 7.9
Summary: [ESXi][RHEL7.9]Rebase open-vm-tools to 11.0.5 for RHEL 7.9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: open-vm-tools
Version: 7.9
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 7.9
Assignee: Miroslav Rezanina
QA Contact: ldu
URL:
Whiteboard:
Depends On:
Blocks: 1718861
TreeView+ depends on / blocked
 
Reported: 2020-02-24 18:02 UTC by Rick Barry
Modified: 2020-10-12 09:00 UTC (History)
14 users (show)

Fixed In Version: open-vm-tools-11.0.5-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-29 19:47:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:3895 0 None None None 2020-09-29 19:48:03 UTC

Description Rick Barry 2020-02-24 18:02:39 UTC
Rebase open-vm-tools to 11.0.5 for RHEL 7.9.

Comment 7 Cathy Avery 2020-02-26 15:09:48 UTC
Ravindra,

Fedora has added run-vmblock\\x2dfuse.mount and open-vm-tools.conf for 11.0.5. Do we need to pick these up?

Thanks,

Cathy

Comment 8 Ravindra Kumar 2020-02-26 20:55:24 UTC
(In reply to Cathy Avery from comment #7)
> Fedora has added run-vmblock\\x2dfuse.mount and open-vm-tools.conf for
> 11.0.5. Do we need to pick these up?

These are not related to 11.0.5 as such. These were added by this commit - https://src.fedoraproject.org/rpms/open-vm-tools/c/75eb4764415485104cf03dd9d9daa60c0a546615?branch=master. This change was needed to fix a pre-existing issue with drag-n-drop. So, in order to make drag-n-drop work for RHEL with GUI, we need this commit. I'm bit surprised that no RHEL customer ever reported any issue with drag-n-drop functionality. This change can be included in older streams if customers using GUI have reported issues with drag-n-drop.

Comment 11 John Savanyo 2020-02-27 18:23:49 UTC
(In reply to Ravindra Kumar from comment #8)
> These are not related to 11.0.5 as such. These were added by this commit -
> https://src.fedoraproject.org/rpms/open-vm-tools/c/
> 75eb4764415485104cf03dd9d9daa60c0a546615?branch=master. This change was
> needed to fix a pre-existing issue with drag-n-drop. So, in order to make
> drag-n-drop work for RHEL with GUI, we need this commit. I'm bit surprised
> that no RHEL customer ever reported any issue with drag-n-drop
> functionality. This change can be included in older streams if customers
> using GUI have reported issues with drag-n-drop.

Hi Cathy, If this change needs to be added to older rhel releases as a z-stream, then would it be better to track adding this as separate BZ since it is unrelated to 11.0.5?  I think we should create a separate drag-n-drop BZ.

Comment 12 John Savanyo 2020-02-27 18:39:23 UTC
Can you please also include this patch with the rebase?
https://github.com/vmware/open-vm-tools/commits/stable-11.0.5-appinfo

thanks,
John

Comment 13 Cathy Avery 2020-02-27 18:52:42 UTC
(In reply to John Savanyo from comment #12)
> Can you please also include this patch with the rebase?
> https://github.com/vmware/open-vm-tools/commits/stable-11.0.5-appinfo
> 
> thanks,
> John

John,

Is this the commit you want?

https://github.com/vmware/open-vm-tools/commit/f1f0b812e7fb9ccf405fcfd48ddb4d65e8532eef

Comment 14 John Savanyo 2020-02-27 18:54:57 UTC
(In reply to Cathy Avery from comment #13)
> (In reply to John Savanyo from comment #12)
> > Can you please also include this patch with the rebase?
> > https://github.com/vmware/open-vm-tools/commits/stable-11.0.5-appinfo
> > 
> > thanks,
> > John
> 
> John,
> 
> Is this the commit you want?
> 
> https://github.com/vmware/open-vm-tools/commit/
> f1f0b812e7fb9ccf405fcfd48ddb4d65e8532eef

Hi Oliver, Can you confirm?

Comment 15 Oliver Kurth 2020-02-27 19:10:06 UTC
> > Is this the commit you want?
> > 
> > https://github.com/vmware/open-vm-tools/commit/
> > f1f0b812e7fb9ccf405fcfd48ddb4d65e8532eef
> 
> Hi Oliver, Can you confirm?

Yes, that is correct. There is only one commit in that branch.

Comment 16 Cathy Avery 2020-02-28 12:22:28 UTC
(In reply to John Savanyo from comment #12)
> Can you please also include this patch with the rebase?
> https://github.com/vmware/open-vm-tools/commits/stable-11.0.5-appinfo
> 
> thanks,
> John

I'll create BZs for this patch for 7.9 and 8.2.1 and I'll add the patch when the respective rebases are done.

The fuse patch will have to have z-stream BZs created for RHEL 7. 

Is there a rev of open-vm-tools where the fuse patch is not appropriate? The oldest rev it would be applied to in z-stream is 10.2.5.

Comment 17 Miroslav Rezanina 2020-02-28 12:27:49 UTC
(In reply to Cathy Avery from comment #16)
> (In reply to John Savanyo from comment #12)
> > Can you please also include this patch with the rebase?
> > https://github.com/vmware/open-vm-tools/commits/stable-11.0.5-appinfo
> > 
> > thanks,
> > John
> 
> I'll create BZs for this patch for 7.9 and 8.2.1 and I'll add the patch when
> the respective rebases are done.
> 
> The fuse patch will have to have z-stream BZs created for RHEL 7. 
> 
> Is there a rev of open-vm-tools where the fuse patch is not appropriate? The
> oldest rev it would be applied to in z-stream is 10.2.5.

Do we really need to get this to z-stream? As this wasn't reported by any customer, 
we can have the fix in y-stream only and handle z-stream when requested by customer.

Comment 18 Ravindra Kumar 2020-02-28 20:36:08 UTC
(In reply to Cathy Avery from comment #16)
> Is there a rev of open-vm-tools where the fuse patch is not appropriate? The
> oldest rev it would be applied to in z-stream is 10.2.5.

Cathy, the drag-n-drop fix mainly adds a Systemd unit file to create a Fuse mount point. It should work fine with older versions of open-vm-tools. Please let me know if you are going to create RHBZ for this or need us to create for you? We will probably need at least 2, one for 7.x and another for 8.x.

Comment 19 John Savanyo 2020-02-28 20:47:09 UTC
(In reply to Miroslav Rezanina from comment #17)
> > I'll create BZs for this patch for 7.9 and 8.2.1 and I'll add the patch when
> > the respective rebases are done.
> > 
> > The fuse patch will have to have z-stream BZs created for RHEL 7. 
> > 
> > Is there a rev of open-vm-tools where the fuse patch is not appropriate? The
> > oldest rev it would be applied to in z-stream is 10.2.5.
> 
> Do we really need to get this to z-stream? As this wasn't reported by any
> customer, 
> we can have the fix in y-stream only and handle z-stream when requested by
> customer.

Please share BZs. Or let us know if you want us to create.

For now let's fix in future releases 7.9 and 8.2.1.  

FYI. ESXi does not support drag-n-drop. Support of this feature is limited to VMware Workstation and VMware Fusion products. I'll reach out to team responsible for these products if they can provide business case to better justify z-stream back ports. And I'll ask how far back this issue affects RHEL/OVT releases.

Comment 20 John Savanyo 2020-02-28 21:34:05 UTC
(In reply to Cathy Avery from comment #16)
> Is there a rev of open-vm-tools where the fuse patch is not appropriate? The
> oldest rev it would be applied to in z-stream is 10.2.5.

Ravindra said this change will work with older OVT releases, which should include 10.2.5.

Comment 21 Rick Barry 2020-03-03 18:25:46 UTC
(In reply to John Savanyo from comment #19)
> (In reply to Miroslav Rezanina from comment #17)
> > > I'll create BZs for this patch for 7.9 and 8.2.1 and I'll add the patch when
> > > the respective rebases are done.
> > > 
> > > The fuse patch will have to have z-stream BZs created for RHEL 7. 
> > > 
> > > Is there a rev of open-vm-tools where the fuse patch is not appropriate? The
> > > oldest rev it would be applied to in z-stream is 10.2.5.
> > 
> > Do we really need to get this to z-stream? As this wasn't reported by any
> > customer, 
> > we can have the fix in y-stream only and handle z-stream when requested by
> > customer.
> 
> Please share BZs. Or let us know if you want us to create.
> 
> For now let's fix in future releases 7.9 and 8.2.1.  
> 
> FYI. ESXi does not support drag-n-drop. Support of this feature is limited
> to VMware Workstation and VMware Fusion products. I'll reach out to team
> responsible for these products if they can provide business case to better
> justify z-stream back ports. And I'll ask how far back this issue affects
> RHEL/OVT releases.

I agree, John. Let's just plan on the 7.9 and 8.3 releases for that drag-n-drop
patch. It's very doubtful we'll get approval to back-port the drag-n-drop patch
for any z-stream since we don't officially support VMware Workstation and VMware
Fusion. ESXi is where our enterprise support is guaranteed.

Comment 22 Ravindra Kumar 2020-03-03 20:48:08 UTC
(In reply to Rick Barry from comment #21)
> Let's just plan on the 7.9 and 8.3 releases for that
> drag-n-drop patch.

Would you guys create BZ for these patches or we need to create those?

Comment 23 Rick Barry 2020-03-03 20:58:02 UTC
(In reply to Ravindra Kumar from comment #22)
> (In reply to Rick Barry from comment #21)
> > Let's just plan on the 7.9 and 8.3 releases for that
> > drag-n-drop patch.
> 
> Would you guys create BZ for these patches or we need to create those?

Cathy can confirm, but the plan is to just pick this up with the 11.0.5 rebase
(this BZ for RHEL 7.9 and bug 1806677 for RHEL 8.3).

Comment 24 Cathy Avery 2020-03-04 12:53:53 UTC
I have added two BZs for the app info patch https://github.com/vmware/open-vm-tools/commit/f1f0b812e7fb9ccf405fcfd48ddb4d65e8532eef

Bug 1809751 - [ESXi][RHEL8.2.1]open-vm-tools add appinfo plugin patch

Bug 1809753 - [ESXi][RHEL7.9]open-vm-tools add appinfo plugin patch

Could you give instruction on how to test it?

To reiterate at this time we will not be adding the fuse drag and drop patch to any z-stream. It will only be picked up by way of rebase for example revs 7.9, 8.2.1, etc.

Comment 28 John Savanyo 2020-03-12 03:32:12 UTC
Ravindra provided information on how to test patch in bug 1809751.

Comment 31 John Savanyo 2020-03-19 23:35:38 UTC
I'm a little confused about plan for adding the fuse drag and drop patch. Comment #23 says 7.9 and 8.3.  Comment #24 says 7.9 and 8.2.1.  Can you please clarify? I think 7.9 and 8.2.1 is better to ensure upgrades from 7.9 to 8.2.1 will not have a regression.

Comment 32 Cathy Avery 2020-03-20 12:17:49 UTC
(In reply to John Savanyo from comment #31)
> I'm a little confused about plan for adding the fuse drag and drop patch.
> Comment #23 says 7.9 and 8.3.  Comment #24 says 7.9 and 8.2.1.  Can you
> please clarify? I think 7.9 and 8.2.1 is better to ensure upgrades from 7.9
> to 8.2.1 will not have a regression.

That was an accidental omission. Comment 24 is correct ... We are including the fuse patches as they are part of the rebases for 7.9, 8.2.1, and 8.3. We will not be back porting those patches to the z-stream. 

Hope that clears things up,

Cathy

Comment 33 ldu 2020-06-30 09:26:32 UTC
Run several round regression test for build open-vm-tools-11.0.5-3.el7.x86_64 on RHEL7.9, no regression issue found, all test cases passed, so change status to verified.

Comment 35 errata-xmlrpc 2020-09-29 19:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (open-vm-tools bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:3895


Note You need to log in before you can comment on or make changes to this bug.