Bug 1806751 - The discover-etcd-initial-cluster tool should archive the data-dir if the target member is unstarted
Summary: The discover-etcd-initial-cluster tool should archive the data-dir if the tar...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks: 1806752
TreeView+ depends on / blocked
 
Reported: 2020-02-24 22:05 UTC by Suresh Kolichala
Modified: 2020-07-13 17:21 UTC (History)
0 users

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
This should have been covered in 4.4.
Clone Of:
: 1806752 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:15 UTC

Description Suresh Kolichala 2020-02-24 22:05:26 UTC
Description of problem:

The discover-etcd-initial-cluster tool should archive the data-dir if the target member is unstarted. This is useful for disaster recovery after restoring a backup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Bring up a single node cluster by restoring the backup on a single master node using the restore DR script.
2. Force CEO redeployment via oc patch forceredpeloymment=reason-time
3. When CEO redeployment is forced, the existing nodes will start with new pods, a scale up similar to bootstrap will take place
4. Actual results:
The other two nodes stay Unstarted because of the existing /var/lib/etcd/member


Expected results:
The scale up occurs correctly.

Additional info:

Comment 3 ge liu 2020-03-08 07:58:07 UTC
Verified on 4.5 0306, the etcd data dir: /var/lib/etcd, could not exist after etcd restore, otherwise, the etcd member pods will not be scale up, only etcd-member.yaml file is necessary.

Comment 5 errata-xmlrpc 2020-07-13 17:20:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.