Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806752 - The discover-etcd-initial-cluster tool should archive the data-dir if the target member is unstarted
Summary: The discover-etcd-initial-cluster tool should archive the data-dir if the tar...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
: 1806542 (view as bug list)
Depends On: 1806751
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-24 22:06 UTC by Suresh Kolichala
Modified: 2020-05-04 11:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1806751
Environment:
Last Closed: 2020-05-04 11:39:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift etcd pull 32 0 None closed Bug 1806752: [release 4.4] Archive data dir if unstarted 4.4 2020-03-08 09:43:18 UTC

Description Suresh Kolichala 2020-02-24 22:06:34 UTC
+++ This bug was initially created as a clone of Bug #1806751 +++

Description of problem:

The discover-etcd-initial-cluster tool should archive the data-dir if the target member is unstarted. This is useful for disaster recovery after restoring a backup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Bring up a single node cluster by restoring the backup on a single master node using the restore DR script.
2. Force CEO redeployment via oc patch forceredpeloymment=reason-time
3. When CEO redeployment is forced, the existing nodes will start with new pods, a scale up similar to bootstrap will take place
4. Actual results:
The other two nodes stay Unstarted because of the existing /var/lib/etcd/member


Expected results:
The scale up occurs correctly.

Additional info:

Comment 1 Suresh Kolichala 2020-02-25 17:00:02 UTC
*** Bug 1806542 has been marked as a duplicate of this bug. ***

Comment 4 ge liu 2020-03-08 09:43:56 UTC
Verified on 4.4 0306.

Comment 6 errata-xmlrpc 2020-05-04 11:39:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.