Bug 1806862 - foomatic-rip produces empty output for printable postscript files
Summary: foomatic-rip produces empty output for printable postscript files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups-filters
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1808198 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 08:18 UTC by Marc Muehlfeld
Modified: 2020-03-13 06:21 UTC (History)
6 users (show)

Fixed In Version: cups-filters-1.27.2-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-11 22:46:11 UTC
Type: Bug


Attachments (Terms of Use)
cups_job_log (17.40 KB, text/plain)
2020-02-25 10:08 UTC, Marc Muehlfeld
no flags Details
cups_whole_log (1.05 MB, text/plain)
2020-02-25 10:08 UTC, Marc Muehlfeld
no flags Details

Description Marc Muehlfeld 2020-02-25 08:18:47 UTC
Description of problem:
After updating to cups-filters-1.27.1-1, printing is no longer possible.



Version-Release number of selected component (if applicable):
cups-filters-1.27.1-1.fc31.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Update to cups-filters-1.27.1-1.fc31.x86_64
2. Print a test page, PDF, ...


Actual results:
Nothing happens. Printer does not even wake up.


Expected results:
Printing should work.


CUPS log:
Feb 25 09:15:49 my-computer cupsd[851]: REQUEST localhost - - "POST / HTTP/1.1" 200 273 Create-Printer-Subscriptions successful-ok
Feb 25 09:15:53 my-computer cupsd[851]: REQUEST localhost - - "POST /printers/SAM2875 HTTP/1.1" 200 408 Print-Job successful-ok
Feb 25 09:15:53 my-computer cupsd[851]: SAM2875 root 84 [25/Feb/2020:09:15:53 +0100] total 1 - localhost Test Page - -
Feb 25 09:15:56 my-computer cupsd[851]: REQUEST localhost - - "POST / HTTP/1.1" 200 152 Cancel-Subscription successful-ok


Additional info:
Printer: Samsung M2875FD
Driver: Samsung M267x 287x Series PXL  (automatically installed by system-config-printer)


Workaround:
Downgrade to cups-filters-1.22.5-4:
# dnf downgrade cups-filters

Comment 1 Zdenek Dohnal 2020-02-25 09:17:39 UTC
Hi Marc,

thank you for reporting the issue!

Would you mind following https://fedoraproject.org/wiki/How_to_debug_printing_problems and provide requested files?

Thank you in advance!

Comment 2 Marc Muehlfeld 2020-02-25 10:08:30 UTC
Created attachment 1665589 [details]
cups_job_log

Comment 3 Marc Muehlfeld 2020-02-25 10:08:57 UTC
Created attachment 1665590 [details]
cups_whole_log

Comment 4 Marc Muehlfeld 2020-02-25 10:12:26 UTC
Further information:

Device: uri = socket://192.168.150.13
        class = network
        info = Samsung M267x 287x Series
        make-and-model = Samsung M267x 287x Series
        device-id = MFG:Samsung;CMD:PCL6,URF,FAX,FWV,PIC,SPDS,EXT;MDL:M267x 287x Series;CLS:PRINTER;CID:SA_PCL6_BW;MODE:FAX3,SCN,SPL3,R000105,SCP;
        location =


/etc/cups/ppd/SAM2875.ppd:*NickName: "Samsung M267x 287x Series PXL"

Comment 5 Zdenek Dohnal 2020-02-25 15:11:43 UTC
Ok, I was able to reproduce the issue with file device printer - resulting file is empty. Checking if it is not due https://github.com/OpenPrinting/cups-filters/issues/206 ...

Comment 6 Zdenek Dohnal 2020-02-25 17:16:46 UTC
Hi Marc,

the upstream fix worked for my local reproducer (output is no longer empty) - would you mind testing the scratch build? The link is https://koji.fedoraproject.org/koji/taskinfo?taskID=41892070 .

Comment 7 Marc Muehlfeld 2020-02-26 07:59:04 UTC
Hi Zdenek.
The RPMs from the scratch build fixes the problem. Thanks.

Comment 8 Zdenek Dohnal 2020-03-02 08:09:52 UTC
*** Bug 1808198 has been marked as a duplicate of this bug. ***

Comment 9 Zdenek Dohnal 2020-03-02 13:32:49 UTC
I'm currently blocked by FTBFS on F33 and F32 - it was raised by font packaging change and the change showed programming error in cups-filters. I'll create the patch for upstream and create pull request there.

Comment 10 Fedora Update System 2020-03-02 15:31:20 UTC
FEDORA-2020-83519d93aa has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-83519d93aa

Comment 11 Fedora Update System 2020-03-02 19:57:07 UTC
cups-filters-1.27.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-83519d93aa

Comment 12 Zdenek Dohnal 2020-03-04 09:20:09 UTC
*** Bug 1809763 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2020-03-04 10:03:44 UTC
FEDORA-2020-83519d93aa has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-83519d93aa

Comment 14 Albert Flügel 2020-03-04 13:36:39 UTC
*** Bug 1809763 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2020-03-04 21:48:39 UTC
cups-filters-1.27.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-83519d93aa

Comment 16 Amin 2020-03-06 21:12:17 UTC
I can confirm similar behavior with foo2xqx backend for HP LaserJet P1505N, connected over LAN.

How i found this:
- at one moment i found that my network printer don't print;
  I try some programs (libreoffice writer, kwrite, lp) and cups test-page - this don't work;
  In logs nothing interesting even in debug log-level;
- I check foo2xqx-wrapper - this work correctly, and print xqx-data directly over lpr - this work correct.
- I try reinstall printer, re-assign PPD file and even make hard-reset for printer.
- After some tests i found that new version of cups-filter broke printing over foo2xqx backend;

When i make rollback to cups-filters-1.22  by dnf downgrade command, my printer start working correctly.
I update all systems packages to last versions, except cups-filters and printer stay working;

But after update cups-filters to 1.27 printing to HP P1505N over network fails.

!! After each change version of cups-related packages i make `service cups retart`;

Also i found foo2xqx-wrapper wrote some detailed logs in journal at manual running,
but in printing process from gui-applications with cups-filters-1.27 this xqx-related logs don't appear in journalctl -f;


I suggest that new version of cups-filters-1.27 don't processing this option from PPD-file:

$ zcat /usr/share/cups/model/HP-LaserJet_P1505n.ppd.gz | grep xqx-wrapper
*FoomaticRIPCommandLine: "foo2xqx-wrapper %A"

due absent of foo2xqx-wrapper related strings in cups logs;


I found that another cups-related packages can be upgraded to last versions;

bluez-cups.x86_64           5.53-2.fc31
cups.x86_64                 1:2.2.12-3.fc31
cups-client.x86_64          1:2.2.12-3.fc31
cups-filesystem.noarch      1:2.2.12-3.fc31
cups-filters.x86_64         1.22.5-4.fc31
cups-filters-libs.x86_64    1.22.5-4.fc31
cups-ipptool.x86_64         1:2.2.12-3.fc31
cups-libs.i686              1:2.2.12-3.fc31
cups-libs.x86_64            1:2.2.12-3.fc31
cups-pdf.x86_64             3.0.1-8.fc31
cups-pk-helper.x86_64       0.2.6-8.fc31
python3-cups.x86_64         1.9.74-4.fc31

Comment 17 Amin 2020-03-06 21:24:16 UTC
I also check foomatic-rip outputs - yes, after upgrade cups-filters (and cups-filters-libs) from 1.22 to 1.27 i see only this:

# foomatic-rip /tmp/Check.ps -P HP-P1505n
DEBUG: Color Manager: Invalid printer name.
'CM Color Calibration' Mode in SPOOLER-LESS: Off

# foomatic-rip /tmp/Check.ps -P Cups-PDF 
DEBUG: Color Manager: Invalid printer name.
'CM Color Calibration' Mode in SPOOLER-LESS: Off



At version 1.22 i see also this headers:
12345X@PJL JOB
@PJL SET JAMRECOVERY=OFF
@PJL SET DENSITY=3
@PJL SET ECONOMODE=OFF
@PJL SET RET=MEDIUM
@PJL INFO STATUS
@PJL USTATUS DEVICE = ON
@PJL USTATUS JOB = ON
@PJL USTATUS PAGE = ON
@PJL USTATUS TIMED = 30

and many binary output.

I use only stable version of fc31 repos (`fedora` and `updates`), not devel/testing/rawhide;

Comment 18 Zdenek Dohnal 2020-03-09 09:32:06 UTC
Hi Amin,

thank you for feedback!

As you can see, the bugzilla is in ON_QA, which means the update which fixes the issue is in fedora-updates-testing repository.

Then you can:

1) wait till the update gets through the testing period and get into stable 

or

2) help with testing, installing the cups-filters packages from fedora-updates-testing repo by:

$ sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-83519d93aa

and try to print. Then leave the karma here https://bodhi.fedoraproject.org/updates/FEDORA-2020-83519d93aa depending on your testing results and speed up the testing period.

Comment 19 Fedora Update System 2020-03-11 22:46:11 UTC
cups-filters-1.27.2-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Amin 2020-03-13 06:21:55 UTC
I make update to cups-filters-1.27.2-1 (stable repo) - and my printer work again.
This update fix issue completely. Great work!


Note You need to log in before you can comment on or make changes to this bug.