Bug 1808198 - cups-filters 1.27.1 doesn't not work with my filter set
Summary: cups-filters 1.27.1 doesn't not work with my filter set
Keywords:
Status: CLOSED DUPLICATE of bug 1806862
Alias: None
Product: Fedora
Classification: Fedora
Component: cups-filters
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 05:07 UTC by Rick Richardson
Modified: 2020-03-02 08:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-02 08:09:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Rick Richardson 2020-02-28 05:07:29 UTC
cups-filters 1.27.1 doesn't not work with my filter set, but cups-filters 1.27.0 does work with my filter set.

For example, an HP Laserjet 1102w at network address 192.168.1.15:9100 does this:

1.27.0:
$ lpr testpage.ps
***testpage.ps printed***
$

1.27.1:
$ lpr testpage.ps
***no printout, but X11 notification says it was printed***
$ 

It looks like cups is doing something, but my drivers aren't invoked.

My drivers are here: http://foo2zjs.rkkda.com/.  There are ~50 sub-drivers for lots of printers HP, Konica Minolta, Samsung, Xerox, etc.

This is with Fedora 30 and Fedora 31.

Comment 1 Zdenek Dohnal 2020-02-28 05:41:14 UTC
Hi Rick,

thank you for reporting the issue! It seems like the issue #1806862 - foomatic-rip recognizes certain files as empty. Would you mind trying the rpms posted there? (I hope they did not get cleaned up yet...)

Comment 2 Rick Richardson 2020-02-28 05:59:46 UTC
I tried F31 on a Virtual Box session and it worked.

But, my real system is F30, and you don't have rpms for it.  I need this ASAP for F30!!!!

Comment 4 Zdenek Dohnal 2020-03-02 08:09:52 UTC
(In reply to Rick Richardson from comment #2)
> But, my real system is F30, and you don't have rpms for it.  I need this
> ASAP for F30!!!!

I'll create the update for F30 for sure, but I do not know when or if it will arrive to stable repos - F30 is EOL soon IIRC.

*** This bug has been marked as a duplicate of bug 1806862 ***


Note You need to log in before you can comment on or make changes to this bug.