Bug 1806875 - Wrong sort criteria for capacity on console
Summary: Wrong sort criteria for capacity on console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1807293
TreeView+ depends on / blocked
 
Reported: 2020-02-25 09:01 UTC by shahan
Modified: 2020-07-13 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: pvc's were sorted by alpha Consequence: wrong sort order occurred Fix: sort numerically Result: provided correct sort order
Clone Of:
: 1807291 1807293 1807294 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4521 None closed Bug 1806875: Fix sort criteria for capacity on console 2020-08-26 05:38:16 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:21:25 UTC

Description shahan 2020-02-25 09:01:04 UTC
Description of problem:
Wrong sort criteria for capacity on console. sort criteria for pvc capacity should be numeric sort not the dictionary order

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-24-105333

How reproducible:
Always

Steps to Reproduce:
1. create several PVCs with 1Gi/10Gi/4GI size
2. The goto storage->pvc page and select all-project 
3. try to sort item by capacity

Actual results:
The items sorted based on dictionary order

Expected results:
sort criteria for pvc capacity should be numeric sort

Additional info:

Comment 4 shahan 2020-02-28 09:18:29 UTC
sort criteria for pvc/pv capacity is numeric sort
4.5.0-0.ci-2020-02-28-043432

Comment 7 errata-xmlrpc 2020-07-13 17:20:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.