Bug 1807294 - Wrong sort criteria for capacity on console [NEEDINFO]
Summary: Wrong sort criteria for capacity on console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Yadan Pei
QA Contact: shahan
URL:
Whiteboard:
Depends On: 1807291
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 02:11 UTC by shahan
Modified: 2020-05-13 11:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1806875
Environment:
Last Closed: 2020-05-13 11:07:17 UTC
Target Upstream Version:
vlaad: needinfo? (hasha)


Attachments (Terms of Use)
Sort By Capacity Works (237.50 KB, image/png)
2020-04-17 07:03 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4688 None closed [release-4.2] Bug 1807294: Fix sort criteria for capacity for storage tables 2020-05-08 14:07:19 UTC
Red Hat Product Errata RHBA-2020:2023 None None None 2020-05-13 11:07:37 UTC

Description shahan 2020-02-26 02:11:32 UTC
+++ This bug was initially created as a clone of Bug #1806875 +++

Description of problem:
Wrong sort criteria for capacity on console. sort criteria for pvc capacity should be numeric sort not the dictionary order

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-24-105333

How reproducible:
Always

Steps to Reproduce:
1. create several PVCs with 1Gi/10Gi/4GI size
2. The goto storage->pvc page and select all-project 
3. try to sort item by capacity

Actual results:
The items sorted based on dictionary order

Expected results:
sort criteria for pvc capacity should be numeric sort

Additional info:

Comment 3 shahan 2020-03-03 03:36:46 UTC
I did not see any pr attached here, move the status to modified firstly.

Comment 6 shahan 2020-03-06 07:30:07 UTC
It has no pr attached here and issue still can be reproduced. move to assigned firstly

Comment 11 Yadan Pei 2020-04-17 07:03:55 UTC
Created attachment 1679578 [details]
Sort By Capacity Works

1. Create some PVCs requesting different storage
2. sort by Capacity on PVC list page, the ordering work well

Verified on 4.2.0-0.nightly-2020-04-16-162856

Comment 15 errata-xmlrpc 2020-05-13 11:07:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2023


Note You need to log in before you can comment on or make changes to this bug.