Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806914 - Dev Catalog should always take us to Topology when in Dev Perspective
Summary: Dev Catalog should always take us to Topology when in Dev Perspective
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Sahil Budhwar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1810382
TreeView+ depends on / blocked
 
Reported: 2020-02-25 10:06 UTC by Sahil Budhwar
Modified: 2020-07-13 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1810382 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:20:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4459 0 None closed Bug 1806914: redirect to topology when resource created from dev-catalog 2020-06-23 08:48:02 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:25 UTC

Description Sahil Budhwar 2020-02-25 10:06:09 UTC
Description of problem:
When we create some items through the dev-catalog we don't navigate to the topology and this is confusing to the user.

Note: Typically the offenders are Operator Backed instances, which take us to the "Installed Operators resources" page.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to Add flow. Open dev catalog
2. Install operator backed or template
3. Notice, Page redirects to the details page of installed resource

Actual results:
Page redirects to the details page of installed resource

Expected results:
Should redirect to topology page

Additional info:

Comment 3 Gajanan More 2020-03-10 11:15:16 UTC
I have validated this bug on
Build: 4.5.0-0.ci-2020-03-10-023720
Browser: Google Chrome 78.0.3904.108
Marking this bug as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:20:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.