Bug 1810382 - Dev Catalog should always take us to Topology when in Dev Perspective
Summary: Dev Catalog should always take us to Topology when in Dev Perspective
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sahil Budhwar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1806914
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 06:21 UTC by Sahil Budhwar
Modified: 2020-05-13 22:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1806914
Environment:
Last Closed: 2020-05-13 22:00:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dev Catalog should always take us to Topology when in Dev Perspective (385.30 KB, video/webm)
2020-03-06 22:56 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4661 0 None closed [release-4.4] Bug 1810382: redirect to topology when resource created from dev-catalog 2020-04-27 08:57:24 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:44 UTC

Description Sahil Budhwar 2020-03-05 06:21:55 UTC
+++ This bug was initially created as a clone of Bug #1806914 +++

Description of problem:
When we create some items through the dev-catalog we don't navigate to the topology and this is confusing to the user.

Note: Typically the offenders are Operator Backed instances, which take us to the "Installed Operators resources" page.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to Add flow. Open dev catalog
2. Install operator backed or template
3. Notice, Page redirects to the details page of installed resource

Actual results:
Page redirects to the details page of installed resource

Expected results:
Should redirect to topology page

Additional info:

Comment 3 spathak@redhat.com 2020-03-06 21:59:42 UTC
Verified on build : 4.4.0-0.ci-2020-03-06-112507
Chrome browser: 76.0.3809.132

Comment 4 spathak@redhat.com 2020-03-06 22:56:44 UTC
Created attachment 1668227 [details]
Dev Catalog should always take us to Topology when in Dev Perspective

Comment 6 errata-xmlrpc 2020-05-13 22:00:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.