Bug 1806967 - getCapabilities should report nameservers only once
Summary: getCapabilities should report nameservers only once
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: 4.40.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.4.3
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1806969
Blocks: 1801715
TreeView+ depends on / blocked
 
Reported: 2020-02-25 11:30 UTC by Dominik Holler
Modified: 2020-09-16 07:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-16 07:57:56 UTC
oVirt Team: Network
mperina: ovirt-4.5?


Attachments (Terms of Use)
terminal log of reproducer (23.66 KB, text/plain)
2020-02-25 11:30 UTC, Dominik Holler
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1809640 0 unspecified CLOSED Engine should not explode if host reports duplicated nameservers 2021-02-22 00:41:40 UTC

Description Dominik Holler 2020-02-25 11:30:12 UTC
Created attachment 1665623 [details]
terminal log of reproducer

Description of problem:
If two interfaces are connected to the same subnet and the nameservers which are availbile via this subnet are reported twice.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Connect two NICs to the same subnet which is connected to the name server
2. vdsm-client Host getCapabilities
3.

Actual results:
vdsm-client Host getCapabilities result contains two entries for the same nameserver

Expected results:
vdsm-client Host getCapabilities result contains only a single entries for the same nameserver

Additional info:

Comment 1 SATHEESARAN 2020-03-03 13:47:55 UTC
Dominik,

RHHI-V ( RHV-RHGS Hyperconverged ) setup uses 2 networks.
One for 'ovirtmgmt' and the other for 'storage' (gluster) network.

In this case, we see that there are 2 nameservers returned by '#vdsm-client Host getCapabilities'

[root@ ~]# nmcli con show
NAME      UUID                                  TYPE      DEVICE   
ens3f0    e484732d-cc64-4ee2-b7be-cd4e15239c68  ethernet  ens3f0   
enp4s0f0  d008da26-a9b4-4e14-b3b5-b3aeaaaa2c62  ethernet  enp4s0f0 
virbr0    6a785ab2-d603-4c48-aa83-730678d3a0b9  bridge    virbr0   
vnet0     ff2d8357-198b-42e7-bd48-a90bb59ef6a8  tun       vnet0    
enp4s0f1  3680c1f3-bc30-4d7c-8b59-20ae8c323fe0  ethernet  --       
ens3f1    4963874e-782f-47af-887e-045989a4ea15  ethernet  --  

[root@ ~]# vdsm-client Host getCapabilities | grep -A7 nameservers
    "nameservers": [
        "10.70.34.2",
        "10.70.34.1",
        "10.68.5.26",
        "10.70.34.2",
        "10.70.34.1",
        "10.75.5.25"
    ],

Because of this problem, HE deployment is failing.

So this needs to be fixed for RHV 4.4.0, so that HE deployment works for RHHI-V

Comment 2 Dominik Holler 2020-09-16 07:57:56 UTC
fixed on nmstate-0.3.5-1.el8.noarch and vdsm-4.40.28-8.git2160839fb.el8.x86_64


Note You need to log in before you can comment on or make changes to this bug.