Bug 1807072 - route-override CNI and whereabouts IPAM CNI should be installed in OpenShift
Summary: route-override CNI and whereabouts IPAM CNI should be installed in OpenShift
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Douglas Smith
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On:
Blocks: 1807067
TreeView+ depends on / blocked
 
Reported: 2020-02-25 14:54 UTC by Douglas Smith
Modified: 2020-07-13 17:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1807067
Environment:
Last Closed: 2020-07-13 17:21:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 456 0 None closed Bug 1807072: Adds route-override-cni and whereabouts for secondary network routing and IPAM 2020-06-23 08:49:41 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:21:40 UTC

Description Douglas Smith 2020-02-25 14:54:25 UTC
+++ This bug was initially created as a clone of Bug #1807067 +++

+++ This bug was initially created as a clone of Bug #1807062 +++

Description of problem: route-override and whereabouts IPAM binaries are not copied to the host systems, and their configurations are not integrated in


How reproducible: Always.


Steps to Reproduce:
1. Install OpenShift

Actual results: Note that no binaries named "route-override" or "whereabouts" appear in the CNI BIN directory on the hosts


Expected results: "route-override" or "whereabouts" appear in the CNI BIN directory on the hosts

Comment 3 Weibin Liang 2020-03-06 14:49:49 UTC
Tested and verified in 4.5.0-0.nightly-2020-03-06-091857

[root@dhcp-41-193 FILE]# oc get clusterversions
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-03-06-091857   True        False         10m     Cluster version is 4.5.0-0.nightly-2020-03-06-091857
[root@dhcp-41-193 FILE]# oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-128-129.us-east-2.compute.internal   Ready    worker   15m   v1.17.1
ip-10-0-143-92.us-east-2.compute.internal    Ready    master   25m   v1.17.1
ip-10-0-155-239.us-east-2.compute.internal   Ready    worker   17m   v1.17.1
ip-10-0-159-170.us-east-2.compute.internal   Ready    master   25m   v1.17.1
ip-10-0-164-63.us-east-2.compute.internal    Ready    master   25m   v1.17.1
ip-10-0-165-146.us-east-2.compute.internal   Ready    worker   17m   v1.17.1
[root@dhcp-41-193 FILE]# oc debug node/ip-10-0-128-129.us-east-2.compute.internal
Starting pod/ip-10-0-128-129us-east-2computeinternal-debug ...
To use host binaries, run `chroot /host`
chroot /host
Pod IP: 10.0.128.129
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host
sh-4.4#  ls /var/lib/cni/bin -lathr
total 152M
-rwxr-xr-x. 1 root root  37M Mar  6 14:33 multus
-rwxr-xr-x. 1 root root 4.0M Mar  6 14:34 bandwidth
-rwxr-xr-x. 1 root root 4.5M Mar  6 14:34 bridge
-rwxr-xr-x. 1 root root  12M Mar  6 14:34 dhcp
-rwxr-xr-x. 1 root root 5.7M Mar  6 14:34 firewall
-rwxr-xr-x. 1 root root 3.0M Mar  6 14:34 flannel
-rwxr-xr-x. 1 root root 4.0M Mar  6 14:34 host-device
-rwxr-xr-x. 1 root root 3.5M Mar  6 14:34 host-local
-rwxr-xr-x. 1 root root 4.2M Mar  6 14:34 ipvlan
-rwxr-xr-x. 1 root root 3.1M Mar  6 14:34 loopback
-rwxr-xr-x. 1 root root 4.2M Mar  6 14:34 macvlan
-rwxr-xr-x. 1 root root 4.0M Mar  6 14:34 portmap
-rwxr-xr-x. 1 root root 4.4M Mar  6 14:34 ptp
-rwxr-xr-x. 1 root root 3.3M Mar  6 14:34 sbr
-rwxr-xr-x. 1 root root 2.8M Mar  6 14:34 static
-rwxr-xr-x. 1 root root 3.2M Mar  6 14:34 tuning
-rwxr-xr-x. 1 root root 4.2M Mar  6 14:34 vlan
-rwxr-xr-x. 1 root root 5.8M Mar  6 14:34 openshift-sdn
-rwxr-xr-x. 1 root root 3.3M Mar  6 14:34 route-override
drwxr-xr-x. 2 root root 4.0K Mar  6 14:34 .
-rwxr-xr-x. 1 root root  37M Mar  6 14:34 whereabouts
drwxr-xr-x. 6 root root   62 Mar  6 14:34 ..
sh-4.4#

Comment 5 errata-xmlrpc 2020-07-13 17:21:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.