Bug 180732 - creative audigy not supported
creative audigy not supported
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 16:33 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 04:09:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
here is the scsound.log (9.86 KB, text/plain)
2006-02-17 06:08 EST, Juergen Bullinger
no flags Details

  None (edit)
Description Juergen Bullinger 2006-02-09 16:33:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
the creative audigy soundcard does not work (no sound is hearable though the soundcard is detected)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install fc5 test2 x86_64 whith soundcard plugged in the computer
2.try to play a test sound
3.
  

Actual Results:  i can not hear anything :o(

Expected Results:  It would be a big advantage if it worked. I guess it is a very common sound card

Additional info:
Comment 1 Martin Stransky 2006-02-13 11:14:48 EST
Could you attach /root/scsound.log file? Can you check alsamixer and unmute/turn
up some channels?
Comment 2 Juergen Bullinger 2006-02-13 17:16:32 EST
Hello Martin,

thank you for your answer. I do not know what finally changed, but now I can at
least hear sound over my speakers. But I am also not sure if this is not the
line out plug, because it is the green socket and not the black one (my goodness
this sounds stupid :o)
Sorry it is not written on the sockets what they are for. I just ckecked all of
them. The only one which worked for the headphones is the blue socket.
The microphone input doesn't work unfortunately. I already toggled the volume
for all the settings in alsamixer. The source is also set to microphone in
alsamixer.
I tried to setup the microphone with the skype echo-service.
Comment 3 Juergen Bullinger 2006-02-13 17:17:32 EST
I forgot to tell, that I have not found a file called scsound.log on my
installation.
Comment 4 Juergen Bullinger 2006-02-15 13:52:13 EST
Can anybody help me how to activate the microphone?
Comment 5 Juergen Bullinger 2006-02-17 04:12:22 EST
Hi I updated my system this night using a yum update and rebooted it afterwards.
Unfortunately the problem still exists.
I already checked the mute, input-source and volume settings and also enabled
capture feedback, but without success. I can not record anything.
Comment 6 Martin Stransky 2006-02-17 04:36:00 EST
Please run system-config-soundcard and it will create the /root/scsound.log.
There are similar bugs:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176727
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167522
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164653
Comment 7 Juergen Bullinger 2006-02-17 06:08:55 EST
Created attachment 124806 [details]
here is the scsound.log

Please not that I hear the testsound, I only can't use the microphone.
Comment 8 Martin Stransky 2006-02-17 08:42:40 EST
btw. did you check the first device? Because you have selected the second device
(line defaults.pcm.device 1 in /etc/asound.conf)
Comment 9 Juergen Bullinger 2006-02-19 14:27:05 EST
What do you mean? Where can I select which device?
I only have one creative audigy in my system. There is a buildin soundcard on my
motherboard but I deactivated it in the bios.

My asound.conf looks like:
# Generated by system-config-soundcard, do not edit by hand
defaults.pcm.card 0
defaults.ctl.card 0

Now unfortunately I also can't hear any sound anymore. I already did yum update
system-config-sound and the alsa packages, but it still doesn't work :o(
What is this?
Comment 10 Martin Stransky 2006-02-20 04:24:51 EST
Your asound.conf looks like this: (according to scsound.log)

#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 1
defaults.pcm.card 0 
defaults.pcm.device 1 
defaults.ctl.card 0 

so you have selected the second device. Please check the first (device 0), put
these lines into /etc/asound.conf and check your card again.

#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0
Comment 11 Juergen Bullinger 2006-02-20 15:52:12 EST
Sorry I think you can forget my message #9 I looked in the config file at my
Fedora Core 4 install. I also hear the sound again. Sorry for this confusion :o(

I put the lines you wrote in message #10 into my /etc/asound.conf file, but it
seems that it doesn,t change anything. My microphone still doesn't work. But I
can still hear the sound. I also tried:

[root@prime /]# alsaunmute 0 -v
Card 0 Driver snd_ca0106 Volume 75%...
Unmuting ...
Unmuting snd_ca0106...
Play. Volume analog front(0) to 191
Play. Volume analog front(1) to 191
Play. Volume analog rear(0) to 191
Play. Volume analog rear(1) to 191
[root@prime /]#

but it also doesn't help :o(

I recognized that if I plug in the microphone in another plug and turn the mic 
to the maximum in alsamixer I hear my voice, but very quiet. I guess this is the
line in and needs to be amplified. In older versions of fedora I had the option
"boost" or something like this, but I couldn't find it in FC5. I also tried
another microphone, but it is not much better :o(
Comment 12 Thomas M Steenholdt 2006-02-21 01:08:42 EST
This looks to me like it's closed in FC5test3... Also bug #178907 seems like a
duplicate (or vica versa) 
Comment 13 Thomas M Steenholdt 2006-02-21 01:09:16 EST
closed of course meaning fixed - yikes! :o)
Comment 14 Juergen Bullinger 2006-02-21 03:50:33 EST
Unfortunately I can't test FC5 test 3 now, because my download limit is reached 
this month :o(
Is it possible to do it over yum somehow or woudn't that save download capacity?
Comment 15 Martin Stransky 2006-02-21 04:03:01 EST
I'm affraid FC5 test 3 won't help you....
Comment 16 Juergen Bullinger 2006-02-21 14:12:58 EST
Have you tried it already?
That's really a shame. I bought this soundcard just because my old one didn't
work anymore. It was also the microphone. So I thought everything would work if
I only buy a new one. Funny :o)
Are the soundblaster cards so different from type to type? I knew times when
every sound card producer had to write "Compatible to SoundBlaster" on their
product. Ohterwise they wouldn't have sold any single piece.
Comment 17 Juergen Bullinger 2006-03-05 13:23:52 EST
I removed the soundcard in the meantime and use my builtin VIA based soundcard
again. The Mic works now. So it was not a problem with my micro. Just with my
soundcard.
The strange thing is, that the microphone monitor output reached my headphones.
I just couldn't record anything. Does this make sense?

It's really a shame, I'll never buy a creative soundcard again in my life. I
always had problems with this stuff!
Comment 18 Martin Stransky 2006-03-07 05:32:04 EST
I think there isn't any problem with HW but with drivers. New cards aren't
usually so well supported under linux as under win because HW vendors aren't so
willing to provide documentation...
Comment 19 Martin Stransky 2006-03-14 07:00:28 EST
Here is "how-to" for recording on ca0106 driver (riped from alsa-driver-1.0.11.rc3):

 *    Notes on how to capture sound:
 *      The AC97 is used in the PLAYBACK direction.
 *      The output from the AC97 chip, instead of reaching the speakers, is fed
into the Philips 1361T ADC.
 *      So, to record from the MIC, set the MIC Playback volume to max,
 *      unmute the MIC and turn up the MASTER Playback volume.
 *      So, to prevent feedback when capturing, minimise the "Capture feedback
into Playback" volume.

I hope it may help you. This driver is still under development...
Comment 20 Juergen Bullinger 2006-03-21 14:03:23 EST
Hello Martin, thank you for your suggestion. In the meantime I already removed
my soundblaster card and use my builtin card again. 
Comment 21 Martin Stransky 2006-03-30 04:09:28 EST
okay, closing as upstream.
Comment 22 Martin Stransky 2006-03-30 04:11:58 EST
btw. how-to for new alsa-drivers (1.0.11rc4) on FC4/5 is here:
http://people.redhat.com/stransky/alsa

Note You need to log in before you can comment on or make changes to this bug.