Bug 180750 - Can't build package, duplicate function set_selinux_context
Can't build package, duplicate function set_selinux_context
Status: CLOSED DUPLICATE of bug 170178
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-09 22:13 EST by John Morris
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 15:50:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Allows package to actually compile (1.24 KB, patch)
2006-02-09 22:16 EST, John Morris
no flags Details | Diff

  None (edit)
Description John Morris 2006-02-09 22:13:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051114 White Box/1.7.12-1.1.3.2.WB1

Description of problem:
Buggered if I know how you guys got the package you shipped to ever build.  Attempts to build get:

/lib/libdevmapper.a(libdm-common.o)(.text+0x55a): In function `set_selinux_context':
/home/buildsys/rpmbuild/BUILD/device-mapper.1.01.04/lib/libdm-common.c:204: multiple definition of `set_selinux_context'
../lib/liblvm.a(selinux.o)(.text+0x0):misc/selinux.c:22: first defined here
/usr/bin/ld: Warning: size of symbol `set_selinux_context' changed from 325 in ../lib/liblvm.a(selinux.o) to 327 in /lib/libdevmapper.a(libdm-common.o)

The problem is devicemapper also has a function named set_selinux_context and is being linked in, hilarity ensues.

Version-Release number of selected component (if applicable):
lvm2-2.01.14-2.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
Try rebuilding the package, watch it go foom.

Apply attached patch and get a clean build.

Additional info:
Comment 1 John Morris 2006-02-09 22:16:14 EST
Created attachment 124471 [details]
Allows package to actually compile
Comment 2 Alasdair Kergon 2006-02-10 15:50:44 EST
Fixed in U3.

*** This bug has been marked as a duplicate of 170178 ***

Note You need to log in before you can comment on or make changes to this bug.