Bug 1807865 - Stale Node remains displayed on VM Overview dashboard after a VM has been stopped
Summary: Stale Node remains displayed on VM Overview dashboard after a VM has been sto...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1807911
TreeView+ depends on / blocked
 
Reported: 2020-02-27 12:01 UTC by Radim Hrazdil
Modified: 2020-07-13 17:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1807911 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:21:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4531 0 None closed Bug 1807865: Don't show node if pod is dead 2020-06-23 08:51:24 UTC
Github openshift console pull 4647 0 None closed Bug 1807865: Don't show node if pod is dead fix 2020-06-23 08:51:23 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:22:11 UTC

Description Radim Hrazdil 2020-02-27 12:01:46 UTC
Description of problem:
Similar issue as BZ1807023.

After stopping a VM, VM Overview page still displayed Node on which the VM was running on. 

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
1. Start VM
2. Stop VM
3. Check Node displayed on Overview page

Actual results:
Stale Node displayed

Expected results:
Should be 'Not available'

Additional info:

Comment 4 Yaacov Zamir 2020-03-05 07:49:24 UTC
https://github.com/openshift/console/pull/4648

Comment 5 Yaacov Zamir 2020-03-05 11:20:59 UTC
Submitted upstream:
https://github.com/openshift/console/pull/4647

Comment 7 Guohua Ouyang 2020-03-31 08:16:21 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 8 Yaacov Zamir 2020-04-30 08:41:32 UTC
docs do not change

Comment 10 errata-xmlrpc 2020-07-13 17:21:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.