Bug 1807911 - Stale Node remains displayed on VM Overview dashboard after a VM has been stopped
Summary: Stale Node remains displayed on VM Overview dashboard after a VM has been sto...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1807865
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 13:11 UTC by Yaacov Zamir
Modified: 2020-05-04 11:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1807865
Environment:
Last Closed: 2020-05-04 11:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4535 0 None closed [release-4.4] Bug 1807911: Don't show node if pod is dead 2020-04-30 08:41:51 UTC
Github openshift console pull 4649 0 None closed [release-4.4] Bug 1807911: Don't show node if pod is dead fix 2020-04-30 08:41:51 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:19 UTC

Description Yaacov Zamir 2020-02-27 13:11:23 UTC
+++ This bug was initially created as a clone of Bug #1807865 +++

Description of problem:
Similar issue as BZ1807023.

After stopping a VM, VM Overview page still displayed Node on which the VM was running on. 

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
1. Start VM
2. Stop VM
3. Check Node displayed on Overview page

Actual results:
Stale Node displayed

Expected results:
Should be 'Not available'

Additional info:

Comment 3 Guohua Ouyang 2020-03-05 05:30:44 UTC
The node is "Not available" on overview even vm is running.
4.4.0-0.nightly-2020-03-02-011520

Comment 4 Yaacov Zamir 2020-03-05 07:40:08 UTC
Hi, Guohua +1

Thanks for the check, this also happen on master so I pushed a PR to master and will backport once that is merged:
https://github.com/openshift/console/pull/4647

Comment 5 Yaacov Zamir 2020-03-05 07:56:20 UTC
https://github.com/openshift/console/pull/4649

Comment 7 Guohua Ouyang 2020-03-12 02:12:09 UTC
verified on 4.4.0-0.nightly-2020-03-06-170328.

Comment 8 Yaacov Zamir 2020-04-30 08:42:21 UTC
no docs change needed

Comment 10 errata-xmlrpc 2020-05-04 11:43:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.