Bug 1807868 - Edit flow for knative Service with image change not creating new revision
Summary: Edit flow for knative Service with image change not creating new revision
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1809178
TreeView+ depends on / blocked
 
Reported: 2020-02-27 12:02 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On editing image name for knative service same existing ImageStream get's updated even if image is completely different. Consequence: Change in image name while editing knative Service is not creating a new revision. Fix: In case of knative service edit, generating new Image Stream with name-randomChars and update service with new image registry url and filtering image stream based on instance name. Result: Change in image name while editing knative Service will trigger a new revision as expected.
Clone Of:
: 1809178 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:21:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4528 None closed Bug 1807868: fixes issue with knative service in edit flow 2020-06-30 17:56:17 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:22:11 UTC

Description Jaivardhan Kumar 2020-02-27 12:02:28 UTC
Description of problem:
On editing knative Service from topology view with different image not creating new revision.

Version-Release number of selected component (if applicable):4.4


How reproducible: Always


Steps to Reproduce:
1. Install serverless operator
2. Go to Add -> container image
3. search for `invincibleJai/tag-portal-v1` and create kn service
4. kn service is created can view in topology
5. Edit kn service
6. Change image from `invincibleJai/tag-portal-v1` to `invincibleJai/scrumola` and save

Actual results: No revision will be created


Expected results:The revision will be created


Additional info:

Comment 3 Gajanan More 2020-03-10 11:14:52 UTC
I have validated this bug on
Build: 4.5.0-0.ci-2020-03-10-023720
Browser: Google Chrome 78.0.3904.108
Marking this bug as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:21:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.