Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1809178 - Edit flow for knative Service with image change not creating new revision
Summary: Edit flow for knative Service with image change not creating new revision
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1807868
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 14:37 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On editing image name for knative service same existing ImageStream get's updated even if image is completely different. Consequence: Change in image name while editing knative Service is not creating a new revision. Fix: In case of knative service edit, generating new Image Stream with name-randomChars and update service with new image registry url and filtering image stream based on instance name. Result: Change in image name while editing knative Service will trigger a new revision as expected.
Clone Of: 1807868
Environment:
Last Closed: 2020-05-04 11:43:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Revision created (287.34 KB, image/png)
2020-03-05 10:43 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4610 0 None closed [release-4.4] Bug 1809178: fixes issue with knative service in edit flow 2020-04-20 12:03:38 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:13 UTC

Description Jaivardhan Kumar 2020-03-02 14:37:25 UTC
+++ This bug was initially created as a clone of Bug #1807868 +++

Description of problem:
On editing knative Service from topology view with different image not creating new revision.

Version-Release number of selected component (if applicable):4.4


How reproducible: Always


Steps to Reproduce:
1. Install serverless operator
2. Go to Add -> container image
3. search for `invincibleJai/tag-portal-v1` and create kn service
4. kn service is created can view in topology
5. Edit kn service
6. Change image from `invincibleJai/tag-portal-v1` to `invincibleJai/scrumola` and save

Actual results: No revision will be created


Expected results:The revision will be created


Additional info:

Comment 3 Gajanan More 2020-03-05 10:43:16 UTC
Created attachment 1667708 [details]
Revision created

Comment 4 Gajanan More 2020-03-05 10:43:51 UTC
I have validated this bug on:
Build: 4.4.0-0.nightly-2020-03-05-014624
Browser: Google Chrome Version 78.0.3904.108
Marking this as verified.

Comment 6 errata-xmlrpc 2020-05-04 11:43:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.