Bug 1807964 - Number of leader changes > 173 for OCP 4.3 on Azure
Summary: Number of leader changes > 173 for OCP 4.3 on Azure
Keywords:
Status: CLOSED DUPLICATE of bug 1807279
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard: aos-scalability-43
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 15:02 UTC by Mohit Sheth
Modified: 2020-04-02 20:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-02 20:43:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mohit Sheth 2020-02-27 15:02:54 UTC
Description of problem:
Got  
>Error from server: rpc error: code = Unavailable desc = etcdserver: leader changed 
when trying oc get pods.

one of the workload (router test) reports
>Unable to connect to the server: dial tcp: i/o timeout
>Unable to connect to the server: dial tcp: i/o timeout

The cloud provider was Azure



Version-Release number of selected component (if applicable):
Cluster version is 4.3.0-rc.3



Actual results:
It was found out that the number of leader elections was > 173

Expected results:
The leader elections should be very low

Additional info:

Comment 3 Sam Batschelet 2020-04-02 20:43:13 UTC

*** This bug has been marked as a duplicate of bug 1807279 ***


Note You need to log in before you can comment on or make changes to this bug.