Bug 1808432 - The project selector should always be "sticky" - [openshift 4.4]
Summary: The project selector should always be "sticky" - [openshift 4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1808436
TreeView+ depends on / blocked
 
Reported: 2020-02-28 14:18 UTC by Karthik Jeeyar
Modified: 2020-05-04 11:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1808436 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:43:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
The project selector should always be "sticky" (88.25 KB, image/png)
2020-02-28 15:32 UTC, spathak@redhat.com
no flags Details
The project selector should always be "sticky" - [openshift 4.4] (96.51 KB, image/png)
2020-02-28 15:46 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4056 None closed Bug 1808432: Make dev-console project selector sticky again 2020-03-04 11:44:10 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:43:59 UTC

Description Karthik Jeeyar 2020-02-28 14:18:55 UTC
Description of problem:

In many of the areas in Dev Perspective, the project selector is no longer "sticky". This is a regression. Doesn't seem to have regressed in any of the areas in the Admin Perspective.

Version-Release number of selected component (if applicable):
4.4

How reproducible:


Steps to Reproduce:
1. Go to any list page in dev console, scroll to the bottom of the page 

Actual results:
Secondary masthead is not visible

Expected results:

Secondary masthead should be visible and sticky.

Comment 1 Karthik Jeeyar 2020-02-28 14:35:33 UTC
This Bug is caused by the changes https://github.com/openshift/console/pull/4210 and it needs to be backported to 4.3 as well.

Comment 4 spathak@redhat.com 2020-02-28 15:32:32 UTC
Created attachment 1666436 [details]
The project selector should always be "sticky"

Comment 5 spathak@redhat.com 2020-02-28 15:46:02 UTC
Created attachment 1666438 [details]
The project selector should always be "sticky" - [openshift 4.4]

Comment 6 spathak@redhat.com 2020-02-28 15:47:25 UTC
Verified on build : 4.4.0-0.ci-2020-02-26-215902
Chrome browser: 76.0.3809.132

Comment 8 errata-xmlrpc 2020-05-04 11:43:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.