Bug 1808436 - The project selector should always be "sticky" - [openshift 4.3]
Summary: The project selector should always be "sticky" - [openshift 4.3]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1808432
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 14:26 UTC by Karthik Jeeyar
Modified: 2020-03-24 14:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Caused due to https://github.com/openshift/console/pull/4210 Consequence: Removes the Secondary Masthead in devconsole topology and in other pages the masthead is no longer sticky. Fix: Modified the styles to bring back the Masthead and made it sticky.
Clone Of: 1808432
Environment:
Last Closed: 2020-03-24 14:34:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
The project selector is "sticky" (151.87 KB, image/png)
2020-03-17 09:16 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4557 None closed [release-4.3] Bug 1808436: Make dev-console project selector sticky again 2020-03-17 03:20:13 UTC
Red Hat Product Errata RHBA-2020:0858 None None None 2020-03-24 14:34:44 UTC

Description Karthik Jeeyar 2020-02-28 14:26:45 UTC
+++ This bug was initially created as a clone of Bug #1808432 +++

Description of problem:

In many of the areas in Dev Perspective, the project selector is no longer "sticky". This is a regression. Doesn't seem to have regressed in any of the areas in the Admin Perspective.

Version-Release number of selected component (if applicable):
4.4

How reproducible:


Steps to Reproduce:
1. Go to any list page in dev console, scroll to the bottom of the page 

Actual results:
Secondary masthead is not visible

Expected results:

Secondary masthead should be visible and sticky.

Comment 1 Karthik Jeeyar 2020-02-28 14:37:52 UTC
This Bug is caused by the changes made in this PR - https://github.com/openshift/console/pull/4210

Comment 4 Gajanan More 2020-03-17 09:16:54 UTC
Created attachment 1670773 [details]
The project selector is "sticky"

Comment 5 Gajanan More 2020-03-17 09:18:46 UTC
I have validated this bugzilla on 
Build: 4.3.0-0.nightly-2020-03-16-193416
Browser: Goggle Chrome Version 78.0.3904.108
Marking this as verified.

Comment 7 errata-xmlrpc 2020-03-24 14:34:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.