Bug 1808874 - [abrt] dmar_walk_remapping_entries: WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4326 dmar_parse_one_rmrr+0x7d/0x12b
Summary: [abrt] dmar_walk_remapping_entries: WARNING: CPU: 0 PID: 0 at drivers/iommu/i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b6e524354c8077150047876193c...
: 1808191 1808919 1809009 1809163 1809377 1809418 1809520 1809543 1809696 1809730 1809976 1810049 1810077 1810246 1811151 1811434 1811661 1811766 1811956 1812187 1812246 1812625 1812793 1812885 1813048 1813183 1813612 1813786 1813899 1814843 1815278 1816525 1817149 1818064 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-01 18:50 UTC by omg.snarf
Modified: 2020-03-27 15:07 UTC (History)
60 users (show)

Fixed In Version: kernel-5.5.9-200.fc31 kernel-5.5.9-100.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-18 02:22:15 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (83.30 KB, text/plain)
2020-03-01 18:50 UTC, omg.snarf
no flags Details
dmesg for 5.5.7-200.fc31 (84.14 KB, text/plain)
2020-03-03 17:28 UTC, omg.snarf
no flags Details
dmesg from kernel 5.4.13-201.fc31 - bug does NOT occur (82.52 KB, text/plain)
2020-03-03 17:33 UTC, omg.snarf
no flags Details

Description omg.snarf 2020-03-01 18:50:27 UTC
Description of problem:
Booted without any other action. Using full disk encryption, Legacy BIOS enabled. Logged into Gnome using user account.

Additional info:
reporter:       libreport-2.12.0
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4326 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.6-201.fc31.x86_64 #1
Hardware name: LENOVO 4236QB1/4236QB1, BIOS 83ET76WW (1.46 ) 07/05/2013
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 d9 49 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 90 65 3f a1 e8 1e 69 0e fe <0f> 0b 48 8b 3d 03 53 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 74 35
RSP: 0000:ffffffffa1603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffb7cf800360c8 RCX: 00000000000000d3
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffffa2600008 R08: 00000000000000d3 R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffffa2600038
R13: ffffffffa1603e58 R14: 0000000000000000 R15: 00000000da46cd88
FS:  0000000000000000(0000) GS:ffff8c7c8e200000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff8c7c9e5ff000 CR3: 000000013c60a001 CR4: 00000000000606b0
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Potential duplicate: bug 1803974

Comment 1 omg.snarf 2020-03-01 18:50:32 UTC
Created attachment 1666809 [details]
File: dmesg

Comment 2 HuangHai 2020-03-02 00:38:06 UTC
*** Bug 1808919 has been marked as a duplicate of this bug. ***

Comment 3 omg.snarf 2020-03-02 01:24:54 UTC
Other details of note:

- This occurs only on a cold boot or reboot, and appears in the Gnome notification window.
- This does not occur after a suspend/resume cycle.
- There does not appear to be any other functionality or behavior impacted - the system is still usable and stable for my personal day-to-day use.


Lists of installed packages available if needed. I am responsive to emails, comments, etc as needed to provide other details, help diagnose, or reproduce.

Comment 4 ktaturu 2020-03-02 09:35:14 UTC
*** Bug 1809009 has been marked as a duplicate of this bug. ***

Comment 5 Joao Luis 2020-03-02 14:13:53 UTC
*** Bug 1809163 has been marked as a duplicate of this bug. ***

Comment 6 Vinicius Reis 2020-03-03 00:15:42 UTC
*** Bug 1809377 has been marked as a duplicate of this bug. ***

Comment 7 Bala 2020-03-03 09:04:57 UTC
Description of problem:
I got this error when I first booted into the system after a system update installed kernel version  5.5.7-200 

Version-Release number of selected component:
kernel-core-5.5.7-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,msdos1)/vmlinuz-5.5.7-200.fc31.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-fd3c2e5c-4c1f-41fb-b30a-3cf76d6c6883 rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/usr rhgb quiet
crash_function: dmar_walk_remapping_entries
kernel:         5.5.7-200.fc31.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.7-200.fc31.x86_64 #1
Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./H110M-STX, BIOS P8.10 04/01/2019
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 69 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 80 67 3f a4 e8 de 58 0e fe <0f> 0b 48 8b 3d 03 43 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 14 25
RSP: 0000:ffffffffa4603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffa9ad0000d410 RCX: 00000000000000cc
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffffa560001c R08: 00000000000000cc R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffffa5600060
R13: ffffffffa4603e58 R14: 0000000000000000 R15: 0000000000000003
FS:  0000000000000000(0000) GS:ffff8e1d4f000000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff8e173a601000 CR3: 000000023960a001 CR4: 00000000000606b0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 8 Gaël Rossignol 2020-03-03 10:16:57 UTC
*** Bug 1809520 has been marked as a duplicate of this bug. ***

Comment 9 Martin 2020-03-03 11:31:48 UTC
*** Bug 1809543 has been marked as a duplicate of this bug. ***

Comment 10 tn 2020-03-03 13:12:36 UTC
Description of problem:
Reported on every boot.  I _believe_ since 5.5.6, but could be wrong.

Possibly related log entries:

```
...
Mar 03 13:51:25 kernel: ACPI: DMAR 0x000000002A2C05F0 0000F0 (v01 INTEL  SKL      00000001 INTL 00000001)
...
Mar 03 13:51:25 kernel: DMAR: Host address width 39
Mar 03 13:51:25 kernel: DMAR: DRHD base: 0x000000fed90000 flags: 0x0
Mar 03 13:51:25 kernel: DMAR: dmar0: reg_base_addr fed90000 ver 1:0 cap 1c0000c40660462 ecap 7e3ff0505e
Mar 03 13:51:25 kernel: DMAR: DRHD base: 0x000000fed91000 flags: 0x1
Mar 03 13:51:25 kernel: DMAR: dmar1: reg_base_addr fed91000 ver 1:0 cap d2008c40660462 ecap f050da
Mar 03 13:51:25 kernel: DMAR: RMRR base: 0x000000373c1000 end: 0x000000373e0fff
Mar 03 13:51:25 kernel: DMAR: RMRR base: 0x0000003b800000 end: 0x0000003fffffff
Mar 03 13:51:25 kernel: DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x000000003b800000-0x000000003fffffff], contact BIOS vendor for fixes
Mar 03 13:51:25 kernel: ------------[ cut here ]------------
Mar 03 13:51:25 kernel: Your BIOS is broken; bad RMRR [0x000000003b800000-0x000000003fffffff]
                                BIOS vendor: Dell Inc.; Ver: 01.02.00; Product Version: 
Mar 03 13:51:25 kernel: WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Mar 03 13:51:25 kernel: Modules linked in:
Mar 03 13:51:25 kernel: CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.7-200.fc31.x86_64 #1
Mar 03 13:51:25 kernel: Hardware name: Dell Inc. XPS 15 9550/0N7TVV, BIOS 01.02.00 04/07/2016
Mar 03 13:51:25 kernel: RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Mar 03 13:51:25 kernel: Code: bf 01 00 00 00 48 89 c5 e8 69 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 80 67 3f b2 e8 de 58 0e fe <0f> 0b 48 8b 3d 03 43 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 14 25
Mar 03 13:51:25 kernel: RSP: 0000:ffffffffb2603e08 EFLAGS: 00010286
Mar 03 13:51:25 kernel: RAX: 0000000000000000 RBX: ffffb5314002d688 RCX: 0000000000000114
Mar 03 13:51:25 kernel: RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
Mar 03 13:51:25 kernel: RBP: ffffffffb360000c R08: 0000000000000114 R09: 0000000000000003
Mar 03 13:51:25 kernel: R10: 0000000000000000 R11: 0000000000000001 R12: ffffffffb213b44c
Mar 03 13:51:25 kernel: R13: ffffffffb2603e58 R14: 000000000000008a R15: 0000000035258e48
Mar 03 13:51:25 kernel: FS:  0000000000000000(0000) GS:ffff9b6aedc00000(0000) knlGS:0000000000000000
Mar 03 13:51:25 kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Mar 03 13:51:25 kernel: CR2: ffff9b6afdfff000 CR3: 000000012260a001 CR4: 00000000000606b0
Mar 03 13:51:25 kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Mar 03 13:51:25 kernel: DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Mar 03 13:51:25 kernel: Call Trace:
Mar 03 13:51:25 kernel:  dmar_walk_remapping_entries+0x76/0x120
Mar 03 13:51:25 kernel:  dmar_table_init+0xdd/0x16d
Mar 03 13:51:25 kernel:  ? dmar_free_dev_scope+0x70/0x70
Mar 03 13:51:25 kernel:  ? intel_iommu_setup+0x20b/0x20b
Mar 03 13:51:25 kernel:  ? iommu_resume+0x1b0/0x1b0
Mar 03 13:51:25 kernel:  ? early_enable_iommus.cold+0x321/0x321
Mar 03 13:51:25 kernel:  ? amd_iommu_apply_ivrs_quirks+0x11/0x11
Mar 03 13:51:25 kernel:  intel_prepare_irq_remapping+0x3d/0x227
Mar 03 13:51:25 kernel:  irq_remapping_prepare+0x1d/0x5f
Mar 03 13:51:25 kernel:  enable_IR_x2apic+0x21/0x188
Mar 03 13:51:25 kernel:  default_setup_apic_routing+0x12/0x6f
Mar 03 13:51:25 kernel:  apic_intr_mode_init+0xc9/0xec
Mar 03 13:51:25 kernel:  x86_late_time_init+0x20/0x25
Mar 03 13:51:25 kernel:  start_kernel+0x493/0x54c
Mar 03 13:51:25 kernel:  secondary_startup_64+0xb6/0xc0
Mar 03 13:51:25 kernel: ---[ end trace 5fcb0c819ef98c90 ]---
Mar 03 13:51:25 kernel: DMAR: ANDD device: 1 name: \_SB.PCI0.I2C0
Mar 03 13:51:25 kernel: DMAR: ANDD device: 2 name: \_SB.PCI0.I2C1
Mar 03 13:51:25 kernel: DMAR-IR: IOAPIC id 2 under DRHD base  0xfed91000 IOMMU 1
Mar 03 13:51:25 kernel: DMAR-IR: HPET id 0 under DRHD base 0xfed91000
Mar 03 13:51:25 kernel: DMAR-IR: x2apic is disabled because BIOS sets x2apic opt out bit.
Mar 03 13:51:25 kernel: DMAR-IR: Use 'intremap=no_x2apic_optout' to override the BIOS setting.
Mar 03 13:51:25 kernel: DMAR: DRHD: handling fault status reg 2
Mar 03 13:51:25 kernel: DMAR: [INTR-REMAP] Request device [f0:1f.0] fault index 1e1a [fault reason 37] Blocked a compatibility format interrupt request
Mar 03 13:51:25 kernel: DMAR-IR: Enabled IRQ remapping in xapic mode
Mar 03 13:51:25 kernel: x2apic: IRQ remapping doesn't support X2APIC mode
...
Mar 03 13:51:25 kernel: DMAR: ACPI device "device:6f" under DMAR at fed91000 as 00:15.0
Mar 03 13:51:25 kernel: DMAR: ACPI device "device:70" under DMAR at fed91000 as 00:15.1
...
Mar 03 13:51:25 kernel: ACPI: AC Adapter [AC] (on-line)
Mar 03 13:51:25 kernel: input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
Mar 03 13:51:25 kernel: ACPI: Lid Switch [LID0]
Mar 03 13:51:25 kernel: input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
Mar 03 13:51:25 kernel: ACPI: Power Button [PBTN]
Mar 03 13:51:25 kernel: input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
Mar 03 13:51:25 kernel: ACPI: Sleep Button [SBTN]
Mar 03 13:51:25 kernel: input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
Mar 03 13:51:25 kernel: ACPI: Power Button [PWRF]
Mar 03 13:51:25 kernel: thermal LNXTHERM:00: registered as thermal_zone0
Mar 03 13:51:25 kernel: ACPI: Thermal Zone [THM] (25 C)
Mar 03 13:51:25 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.LPCB.HEC.ECAV], AE_NOT_FOUND (20191018/psargs-330)
Mar 03 13:51:25 kernel: ACPI Error: Aborting method \_TZ.TZ00._TMP due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Mar 03 13:51:25 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.LPCB.HEC.ECAV], AE_NOT_FOUND (20191018/psargs-330)
Mar 03 13:51:25 kernel: ACPI Error: Aborting method \_TZ.TZ00._TMP due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Mar 03 13:51:25 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.LPCB.HEC.ECAV], AE_NOT_FOUND (20191018/psargs-330)
Mar 03 13:51:25 kernel: ACPI Error: Aborting method \_TZ.TZ01._TMP due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Mar 03 13:51:25 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.LPCB.HEC.ECAV], AE_NOT_FOUND (20191018/psargs-330)
Mar 03 13:51:25 kernel: ACPI Error: Aborting method \_TZ.TZ01._TMP due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Mar 03 13:51:25 kernel: Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled
...

```

Version-Release number of selected component:
kernel-core-5.5.7-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.5.7-200.fc31.x86_64 root=UUID=aaa8ae02-9dd8-4726-9ac6-cb61f94dffaf ro rd.luks.uuid=luks-29b76ad5-20cf-4299-862b-83609dd827d9 rd.luks.uuid=luks-2111d0d3-e43b-4497-9f14-835c97e67cdc rhgb quiet
crash_function: dmar_walk_remapping_entries
kernel:         5.5.7-200.fc31.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.7-200.fc31.x86_64 #1
Hardware name: Dell Inc. XPS 15 9550/0N7TVV, BIOS 01.02.00 04/07/2016
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 69 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 80 67 3f b2 e8 de 58 0e fe <0f> 0b 48 8b 3d 03 43 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 14 25
RSP: 0000:ffffffffb2603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffb5314002d688 RCX: 0000000000000114
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffffb360000c R08: 0000000000000114 R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffffb213b44c
R13: ffffffffb2603e58 R14: 000000000000008a R15: 0000000035258e48
FS:  0000000000000000(0000) GS:ffff9b6aedc00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff9b6afdfff000 CR3: 000000012260a001 CR4: 00000000000606b0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 11 Justin M. Forbes 2020-03-03 16:33:23 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 31 kernel bugs.

Fedora 31 has now been rebased to 5.5.7-200.fc31.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

If you experience different issues, please open a new bug report for those.

Comment 12 jaime.jbmac 2020-03-03 17:14:31 UTC
*** Bug 1809696 has been marked as a duplicate of this bug. ***

Comment 13 omg.snarf 2020-03-03 17:28:44 UTC
Created attachment 1667269 [details]
dmesg for 5.5.7-200.fc31

dmesg for 5.5.7-200.fc31

Comment 14 omg.snarf 2020-03-03 17:30:02 UTC
The crash report/ABRT is resolved and no longer occurs. However the underlying RIP/call trace still occurs as seen in the attached dmesg. I'm not sure if this has always occurred and it just now came to light because of the 5.5.6 crash report. I've got an earlier kernel I can retest with. Will comment with that information shortly.

Comment 15 omg.snarf 2020-03-03 17:33:35 UTC
Created attachment 1667271 [details]
dmesg from kernel 5.4.13-201.fc31 - bug does NOT occur

Comment 16 omg.snarf 2020-03-03 17:37:51 UTC
Retested on kernel 5.4.13-201.fc31.

The underlying issue does NOT occur. Relevant dmesg attached. 

Equivalent DMAR lines as follows:

[    0.299756] ACPI: Core revision 20190816
[    0.299904] clocksource: hpet: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 133484882848 ns
[    0.299918] APIC: Switch to symmetric I/O mode setup
[    0.299920] DMAR: Host address width 36
[    0.299921] DMAR: DRHD base: 0x000000fed90000 flags: 0x0
[    0.299926] DMAR: dmar0: reg_base_addr fed90000 ver 1:0 cap c0000020e60262 ecap f0101a
[    0.299927] DMAR: DRHD base: 0x000000fed91000 flags: 0x1
[    0.299929] DMAR: dmar1: reg_base_addr fed91000 ver 1:0 cap c9008020660262 ecap f0105a
[    0.299930] DMAR: RMRR base: 0x000000da8d5000 end: 0x000000da8ebfff
[    0.299931] DMAR: RMRR base: 0x000000db800000 end: 0x000000df9fffff
[    0.299933] DMAR-IR: IOAPIC id 2 under DRHD base  0xfed91000 IOMMU 1
[    0.299933] DMAR-IR: HPET id 0 under DRHD base 0xfed91000
[    0.299934] DMAR-IR: Queued invalidation will be enabled to support x2apic and Intr-remapping.
[    0.300306] DMAR-IR: Enabled IRQ remapping in x2apic mode
[    0.300307] x2apic enabled
[    0.300314] Switched APIC routing to cluster x2apic.

Comment 17 canarcho 2020-03-03 18:51:44 UTC
*** Bug 1809730 has been marked as a duplicate of this bug. ***

Comment 18 drsaca007 2020-03-04 09:58:04 UTC
Description of problem:
Linux localhost.localdomain 5.5.7-200.fc31.x86_64 #1 SMP Fri Feb 28 17:18:37 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Fedora system warning message

Version-Release number of selected component:
kernel-core-5.5.7-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.5.7-200.fc31.x86_64 root=/dev/mapper/fedora_gn--sbakos-root ro resume=/dev/mapper/fedora_gn--sbakos-swap rd.lvm.lv=fedora_gn-sbakos/root rd.lvm.lv=fedora_gn-sbakos/swap rhgb quiet systemd.unified_cgroup_hierarchy=0
crash_function: dmar_walk_remapping_entries
kernel:         5.5.7-200.fc31.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.7-200.fc31.x86_64 #1
Hardware name: Dell Inc. Vostro 5568/0927W0, BIOS 1.3.0 09/11/2017
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 69 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 80 67 3f 85 e8 de 58 0e fe <0f> 0b 48 8b 3d 03 43 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 14 25
RSP: 0000:ffffffff85603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffb2dc40021868 RCX: 00000000000000fe
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffff8660000c R08: 00000000000000fe R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffff8513b44c
R13: ffffffff85603e58 R14: 000000007248ac60 R15: 00000000775cc848
FS:  0000000000000000(0000) GS:ffff9fd837400000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff9fd78b601000 CR3: 00000001ca60a001 CR4: 00000000000606b0
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 19 udayrao.28 2020-03-04 10:33:15 UTC
*** Bug 1809976 has been marked as a duplicate of this bug. ***

Comment 20 hebertjulio 2020-03-04 13:42:00 UTC
*** Bug 1810049 has been marked as a duplicate of this bug. ***

Comment 21 Alberto Gucciardi 2020-03-04 14:17:09 UTC
*** Bug 1810077 has been marked as a duplicate of this bug. ***

Comment 22 pasbern@zoho.com 2020-03-04 19:14:09 UTC
*** Bug 1810246 has been marked as a duplicate of this bug. ***

Comment 23 kyle.q.miller 2020-03-06 17:54:12 UTC
*** Bug 1811151 has been marked as a duplicate of this bug. ***

Comment 24 Bojan Smojver 2020-03-07 08:00:33 UTC
Description of problem:
Boot on T450s

Version-Release number of selected component:
kernel-core-5.5.8-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,gpt4)/vmlinuz-5.5.8-200.fc31.x86_64 root=UUID=cdcdec93-db52-4050-acbe-180353cf4eb8 ro
crash_function: dmar_walk_remapping_entries
kernel:         5.5.8-200.fc31.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.8-200.fc31.x86_64 #1
Hardware name: LENOVO 20BXCTO1WW/20BXCTO1WW, BIOS JBET73WW (1.37 ) 08/14/2019
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 ef 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 d0 67 3f 99 e8 c4 58 0e fe <0f> 0b 48 8b 3d e9 42 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 5a 24
RSP: 0000:ffffffff99603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffab880004b090 RCX: 00000000000000df
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000246
RBP: ffffffff9a6001a4 R08: 00000000000000df R09: 0720072007200720
R10: 0720072007200720 R11: 0720072007200720 R12: ffffffff9a600014
R13: ffffffff99603e58 R14: 00000000c1152d70 R15: 0000000000000000
FS:  0000000000000000(0000) GS:ffff9a06a5c00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff9a05ad601000 CR3: 000000012c60a001 CR4: 00000000000606b0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 25 Dmitry Dyachenko 2020-03-08 16:20:35 UTC
*** Bug 1811434 has been marked as a duplicate of this bug. ***

Comment 26 DV 2020-03-08 21:07:51 UTC
Description of problem:
after update

Version-Release number of selected component:
kernel-core-5.5.7-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.5.7-200.fc31.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-98bcfeba-0c3c-4145-9501-e2ee765ae859 rd.lvm.lv=fedora/swap rhgb quiet
crash_function: dmar_walk_remapping_entries
kernel:         5.5.7-200.fc31.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.7-200.fc31.x86_64 #1
Hardware name: FUJITSU LIFEBOOK E751/FJNB223, BIOS Version 1.21 06/20/2012
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 69 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 80 67 3f 8a e8 de 58 0e fe <0f> 0b 48 8b 3d 03 43 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 14 25
RSP: 0000:ffffffff8a603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffb2f14002c0c8 RCX: 00000000000000c3
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffff8b600028 R08: 00000000000000c3 R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffff8b60005c
R13: ffffffff8a603e58 R14: 0000000000000000 R15: 00000000c8fff348
FS:  0000000000000000(0000) GS:ffff945fa7a00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff945fafdff000 CR3: 000000018d60a001 CR4: 00000000000606b0
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 27 Hans de Goede 2020-03-09 11:26:48 UTC
*** Bug 1808191 has been marked as a duplicate of this bug. ***

Comment 28 Hans de Goede 2020-03-09 11:37:20 UTC
*** Bug 1809418 has been marked as a duplicate of this bug. ***

Comment 29 Hans de Goede 2020-03-09 11:43:38 UTC
The problem is that the iommu kernel folks are using the WARN_TAINT macro to complain about a firmware bug (which we cannot really fix) causing a backtrace instead of them just printing a warning.

I'm working on a fix for this now (change the WARN_TAINT to just printing a warning).

Comment 30 Marcus Santos 2020-03-09 13:49:03 UTC
*** Bug 1811661 has been marked as a duplicate of this bug. ***

Comment 31 Hans de Goede 2020-03-09 16:59:33 UTC
I've added the patches fixing this to dist-git, so that they will be picked up by the next official build.

Comment 32 dmitryskibitskiy 2020-03-09 17:43:18 UTC
*** Bug 1811766 has been marked as a duplicate of this bug. ***

Comment 33 D. Hugh Redelmeier 2020-03-10 03:52:08 UTC
Description of problem:
First reboot after "dnf update".

Version-Release number of selected component:
kernel-core-5.5.8-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,gpt6)/boot/vmlinuz-5.5.8-200.fc31.x86_64 root=UUID=b52f4379-156a-44e6-8709-df381edbe9e6 ro resume=UUID=d67983df-8a90-48cb-a22f-8ce6c9a8efb1 rhgb quiet
crash_function: dmar_walk_remapping_entries
kernel:         5.5.8-200.fc31.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.8-200.fc31.x86_64 #1
Hardware name: ASUSTeK COMPUTER INC. UX305CA/UX305CA, BIOS UX305CA.304 04/24/2019
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 ef 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 d0 67 3f 9e e8 c4 58 0e fe <0f> 0b 48 8b 3d e9 42 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 5a 24
RSP: 0000:ffffffff9e603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffba100000bf40 RCX: 00000000000000d6
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffff9f60001c R08: 00000000000000d6 R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffff9f600054
R13: ffffffff9e603e58 R14: 0000000083c26d00 R15: 000000000000ff01
FS:  0000000000000000(0000) GS:ffff9cefebc00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff9ceea6601000 CR3: 000000012560a001 CR4: 00000000000606b0
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 34 Hans de Goede 2020-03-10 10:50:34 UTC
*** Bug 1811956 has been marked as a duplicate of this bug. ***

Comment 35 Jehosafat 2020-03-10 17:57:08 UTC
*** Bug 1812187 has been marked as a duplicate of this bug. ***

Comment 36 Ubiraci Araujo 2020-03-10 20:08:33 UTC
*** Bug 1812246 has been marked as a duplicate of this bug. ***

Comment 37 xqgex.n 2020-03-11 17:54:13 UTC
*** Bug 1812625 has been marked as a duplicate of this bug. ***

Comment 38 peter bednar 2020-03-12 08:12:05 UTC
*** Bug 1812793 has been marked as a duplicate of this bug. ***

Comment 39 kentonv 2020-03-12 12:40:04 UTC
*** Bug 1812885 has been marked as a duplicate of this bug. ***

Comment 40 Fedora Update System 2020-03-12 18:38:26 UTC
FEDORA-2020-57216f2e13 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-57216f2e13

Comment 41 Fedora Update System 2020-03-12 18:38:30 UTC
FEDORA-2020-90a64eda89 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-90a64eda89

Comment 42 canarcho 2020-03-12 19:44:01 UTC
*** Bug 1813048 has been marked as a duplicate of this bug. ***

Comment 43 Tsvyatko Kriviradev 2020-03-13 07:39:34 UTC
*** Bug 1813183 has been marked as a duplicate of this bug. ***

Comment 44 Fedora Update System 2020-03-14 01:01:56 UTC
kernel-5.5.9-200.fc31, kernel-headers-5.5.9-200.fc31, kernel-tools-5.5.9-200.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-90a64eda89

Comment 45 Fedora Update System 2020-03-14 02:20:55 UTC
kernel-5.5.9-100.fc30, kernel-headers-5.5.9-100.fc30, kernel-tools-5.5.9-100.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-57216f2e13

Comment 46 francesco.intini.dev 2020-03-14 19:47:35 UTC
*** Bug 1813612 has been marked as a duplicate of this bug. ***

Comment 47 Jyothish 2020-03-16 04:46:29 UTC
*** Bug 1813786 has been marked as a duplicate of this bug. ***

Comment 48 rschroeder6704 2020-03-16 12:55:20 UTC
*** Bug 1813899 has been marked as a duplicate of this bug. ***

Comment 49 Fedora Update System 2020-03-18 02:22:15 UTC
kernel-5.5.9-200.fc31, kernel-headers-5.5.9-200.fc31, kernel-tools-5.5.9-200.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 50 Fedora Update System 2020-03-18 04:05:10 UTC
kernel-5.5.9-100.fc30, kernel-headers-5.5.9-100.fc30, kernel-tools-5.5.9-100.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 51 Ömer Akgöz 2020-03-18 19:20:12 UTC
*** Bug 1814843 has been marked as a duplicate of this bug. ***

Comment 52 Marcus Santos 2020-03-19 21:16:28 UTC
*** Bug 1815278 has been marked as a duplicate of this bug. ***

Comment 53 jordanofreitas 2020-03-20 07:18:01 UTC
Description of problem:
A mensagem de erro foi exibida logo após o login.

Version-Release number of selected component:
kernel-core-5.5.8-200.fc31

Additional info:
reporter:       libreport-2.12.0
cmdline:        BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.5.8-200.fc31.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet
crash_function: dmar_walk_remapping_entries
kernel:         5.5.8-200.fc31.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at drivers/iommu/intel-iommu.c:4333 dmar_parse_one_rmrr+0x7d/0x12b
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 5.5.8-200.fc31.x86_64 #1
Hardware name: Dell Inc. Inspiron 5457/0WT51R, BIOS 1.1.9 04/25/2016
RIP: 0010:dmar_parse_one_rmrr+0x7d/0x12b
Code: bf 01 00 00 00 48 89 c5 e8 ef 3e 83 fe 48 8b 53 10 48 8b 73 08 4d 89 e1 48 89 c1 49 89 e8 48 c7 c7 d0 67 3f 8b e8 c4 58 0e fe <0f> 0b 48 8b 3d e9 42 46 ff ba 38 00 00 00 be c0 0d 00 00 e8 5a 24
RSP: 0000:ffffffff8b603e08 EFLAGS: 00010286
RAX: 0000000000000000 RBX: ffffb9f3c00450d0 RCX: 0000000000000101
RDX: 0000000000000001 RSI: 0000000000000082 RDI: 0000000000000247
RBP: ffffffff8c60000c R08: 0000000000000101 R09: 0000000000000003
R10: 0000000000000000 R11: 0000000000000001 R12: ffffffff8b13b44c
R13: ffffffff8b603e58 R14: 0000000068e11c80 R15: 0000000074d457c8
FS:  0000000000000000(0000) GS:ffff8fb272c00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff8fb223601000 CR3: 000000042260a001 CR4: 00000000000606b0
Call Trace:
 dmar_walk_remapping_entries+0x76/0x120
 dmar_table_init+0xdd/0x16d
 ? dmar_free_dev_scope+0x70/0x70
 ? intel_iommu_setup+0x20b/0x20b
 ? iommu_resume+0x1b0/0x1b0
 ? early_enable_iommus.cold+0x321/0x321
 ? amd_iommu_apply_ivrs_quirks+0x11/0x11
 intel_prepare_irq_remapping+0x3d/0x227
 irq_remapping_prepare+0x1d/0x5f
 enable_IR_x2apic+0x21/0x188
 default_setup_apic_routing+0x12/0x6f
 apic_intr_mode_init+0xc9/0xec
 x86_late_time_init+0x20/0x25
 start_kernel+0x493/0x54c
 secondary_startup_64+0xb6/0xc0

Comment 54 charles 2020-03-24 08:36:39 UTC
*** Bug 1816525 has been marked as a duplicate of this bug. ***

Comment 55 Michael 2020-03-25 17:01:01 UTC
*** Bug 1817149 has been marked as a duplicate of this bug. ***

Comment 56 Jehosafat 2020-03-27 15:07:11 UTC
*** Bug 1818064 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.