Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1809023 - Independent Mode Installation fails [NEEDINFO]
Summary: Independent Mode Installation fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Bipul Adhikari
QA Contact: Oded
URL:
Whiteboard:
Depends On: 1809019
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 09:46 UTC by Bipul Adhikari
Modified: 2020-08-04 18:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1809019
Environment:
Last Closed: 2020-08-04 18:02:59 UTC
Target Upstream Version:
xiuwang: needinfo? (oviner)


Attachments (Terms of Use)
Independent Mode (83.04 KB, image/png)
2020-05-24 18:25 UTC, Oded
no flags Details
Independent Mode (white screen) (2.68 MB, video/webm)
2020-05-31 12:15 UTC, Oded
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4582 0 None closed [release-4.4] Bug 1809023: Fixed independent mode dashboard issues 2020-07-14 04:02:59 UTC
Github openshift console pull 5580 0 None closed Bug 1809023: Minor fixes in the OCS Installation and Independent Dashboard 2020-07-14 04:02:59 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:03:00 UTC

Description Bipul Adhikari 2020-03-02 09:46:33 UTC
+++ This bug was initially created as a clone of Bug #1809019 +++

Description of problem:
Namespace provided under the wrong field in the JSON request.

Version-Release number of selected component (if applicable): 4.4/5


How reproducible:1/1


Steps to Reproduce:
1.Installed Operators -> OCS -> Storage Cluster( Make sure it supports Indep Mode)
2. Click Independent Mode radio button
3. Import a credentials file and press create

Actual results: It fails


Expected results: Should create a storage cluster CR.


Additional info:

Comment 4 Oded 2020-05-17 13:51:48 UTC
Independent mode should not be visible on OCP 4.4 (since OCS 4.4 doesnt support it)

Comment 5 afrahman 2020-05-18 06:14:14 UTC
Re-targeting to 4.5, since feature pushed to 4.5

Comment 6 Oded 2020-05-24 18:24:16 UTC
Setup:
Provider:AWS
OCP Version:4.5.0-0.nightly-2020-05-24-072501
OCS Version:ocs-operator.v4.5.0-433.ci

I didnt find "Independent Mode radio button" in this setup 
Attached screenshot

Comment 7 Oded 2020-05-24 18:25:12 UTC
Created attachment 1691607 [details]
Independent Mode

Comment 8 Bipul Adhikari 2020-05-26 15:58:23 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1834186
If this bug can be created I am not sure. If this BZ actually failed. For the other bug to fail this has to at least pass.

Comment 9 Bipul Adhikari 2020-05-27 07:19:05 UTC
Just realized the description is slightly off:
Step 1 should be : Installed Operators -> OCS -> Storage Cluster( Make sure it supports Indep Mode) -> Create Storage Cluster
And you should see the radio button on this new page.

Comment 12 Oded 2020-05-31 12:14:30 UTC
Setup:
Provider:AWS
OCP Version: 4.5.0-0.nightly-2020-05-30-025738
OCS Version: ocs-operator.v4.5.0-439.ci

Test process:
1.Go to "Operators" -> "Installed Operators" -> OCS -> Storage Cluster -> "Create OCS Cluster Service"
2.Select "Independent - For external storage"
Result: white screen(need to refresh the web page)
*attached screen record

Comment 13 Oded 2020-05-31 12:15:22 UTC
Created attachment 1693832 [details]
Independent Mode (white screen)

Comment 14 Bipul Adhikari 2020-06-03 16:21:34 UTC
Hi, Oded. This issue was partially affected by OCS Operator. New OCS4.5.0 CI builds are available please try with them.

Comment 15 Oded 2020-06-03 20:12:51 UTC
Setup:
Provider:AWS
OCP Version: 4.5.0-0.nightly-2020-06-03-105031
OCS Version: ocs-operator.v4.5.0-442.ci

Test process:
1.Go to "Operators" -> "Installed Operators" -> OCS -> Storage Cluster -> "Create OCS Cluster Service"
2.Select "Independent - For external storage"
3.Create json file:
data.json:
[{"kind": "ConfigMap", "data": {"maxMonId": "0", "data": "a=10.97.47.226:6789", "mapping": {}}, "name": "rook-ceph-mon-endpoints"}, {"kind": "Secret", "data": {"mon-secret": "mon-secret", "fsid": "b99e887c-9f73-47e7-96cc-33c6f3f39aa9", "cluster-name": "openshift-storage", "admin-secret": "admin-secret"}, "name": "rook-ceph-mon"}, {"kind": "Secret", "data": {"userKey": "AQAwA85ezIXyORAA8YDlVMoyo5+tByxcCZigoQ==", "userID": "client.healthchecker"}, "name": "rook-ceph-operator-creds"}, {"kind": "Secret", "data": {"userKey": "AQDtAc5e/S7JJBAAhh2k1cjM5KszMObC0Wugyg==", "userID": "csi-rbd-node"}, "name": "rook-csi-rbd-node"}, {"kind": "Secret", "data": {"userKey": "AQDtAc5ebRXHFBAAAGwy0lHtt3gYt9Q/9jhzXg==", "userID": "csi-rbd-provisioner"}, "name": "rook-csi-rbd-provisioner"}, {"kind": "Secret", "data": {"adminID": "csi-cephfs-node", "adminKey": "AQDuAc5esOp8DRAAi2cI3nGVBWH++9cOoE9b9g=="}, "name": "rook-csi-cephfs-node"}, {"kind": "Secret", "data": {"adminID": "csi-cephfs-provisioner", "adminKey": "AQDtAc5eHe3DNRAAIe6HHnQRPSABuhj3GzEeoA=="}, "name": "rook-csi-cephfs-provisioner"}, {"kind": "StorageClass", "data": {"pool": "myfs-data0"}, "name": "ceph-rbd"}, {"kind": "StorageClass", "data": {"pool": "myfs-data0", "fsName": "myfs"}, "name": "cephfs"}, {"kind": "StorageClass", "data": {"endpoint": "10.10.212.122:9000"}, "name": "ceph-rgw"}]
4.Upload data.json file
5.Click on Create
6.Check Storage Cluster Status
Nmae:ocs-independent-storagecluster
Kind:StorageCluster	
Phase: Ignored

*Need to test this on RHCS cluster

Comment 16 Bipul Adhikari 2020-06-11 07:59:48 UTC
Verified by connecting to an external RHCS cluster

Comment 18 W. Trevor King 2020-06-30 18:21:35 UTC
Looks like bug 1809019 was VERIFIED in this series targeting 4.5.0.  Maybe this bug should target 4.4?  Checking the two referenced PRs, console#4582 explicitly targeted release-4.4.  console#5580 targeted master, but I'm not sure which release branches it ended up in (looks like this bug was targeting 4.5.0 around when that PR landed [1]).  Probably need some console folks to weigh in on which PRs landed in which versions and should be linked from which bugs.

[1]: https://github.com/openshift/console/pull/5580#issuecomment-634641542

Comment 19 XiuJuan Wang 2020-07-01 01:40:44 UTC
Thanks Trevor.
Bug #1809019 is in 4.5.0, we maybe drop bug #1809023.

Oded,
Could you help confirm comment #18 , which target version this bug should set?

Comment 21 errata-xmlrpc 2020-08-04 18:02:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.