Bug 18091 - Installation failure
Installation failure
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
: 35573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 10:23 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 16:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-02 10:23:05 EDT
I tried install RH7 (Deluxe) using custom w/install indivisual packages.
Adding (or subtracting) a single package results in the failure mentioned
in previous bug reports on anaconda.  If I just select packages (e.g. Emacs
and/or Utilities) without selecting indivisual packages, then it goes
through fine.
Comment 1 Michael Fulbright 2000-10-02 17:05:23 EDT
Which previous bug reports are you referring too?

We need more information in order to try and reproduce your bug.
Comment 2 Need Real Name 2000-10-03 14:22:50 EDT
For example, if I add the package Inti during a custom install (select 
indivisual packages), then I get the error:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20,
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/windows

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 3 Michael Fulbright 2000-10-03 16:35:08 EDT
You were probably also mounting a FAT partition. This is a known bug and we are
working on an errata.
Comment 4 Michael Fulbright 2000-10-03 16:35:24 EDT

*** This bug has been marked as a duplicate of 18032 ***
Comment 5 Brent Fox 2001-04-11 11:35:14 EDT
*** Bug 35573 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.