Bug 35573 - installer crashed after trying to read installed packages
Summary: installer crashed after trying to read installed packages
Status: CLOSED DUPLICATE of bug 18091
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-11 07:41 UTC by erlo
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 15:35:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description erlo 2001-04-11 07:41:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


I am trying to upgrade a 6.2 to 7.0. I have downloaded RPMS and base 
files, copied it to my Win partition. The installer sees it OK, but 
crashes anyway.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1.Copy Files to \RedHat\RPMS and \RedHat\base
2.Boot from floppy generated with dd
3.Crash
	

Actual Results:  Installation failed. Existing installation was not damaged

Expected Results:  An upgrade from 6.2 to 7.0

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in 
upgradeFindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: XFree86-xfs

Local variables in innermost frame:
self: <comps.HeaderList instance at 835cf38>
item: XFree86-xfs

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Comment 1 Brent Fox 2001-04-11 15:35:19 UTC
Something probably went wrong during your download.  This happens quite a lot.
I would recommend redownloading the iso images and burning new cd's.

*** This bug has been marked as a duplicate of 18091 ***


Note You need to log in before you can comment on or make changes to this bug.