Bug 1809283 - [4.3] Multus should not cause machine to go not ready when Multus is updated
Summary: [4.3] Multus should not cause machine to go not ready when Multus is updated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Douglas Smith
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On: 1809285
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 19:06 UTC by Douglas Smith
Modified: 2020-03-24 14:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1809285 (view as bug list)
Environment:
Last Closed: 2020-03-24 14:34:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift multus-cni pull 52 0 None closed Bug 1809283: Removes configuration invalidation [4.3 backport] 2021-01-07 17:47:56 UTC
Red Hat Product Errata RHBA-2020:0858 0 None None None 2020-03-24 14:34:44 UTC

Description Douglas Smith 2020-03-02 19:06:34 UTC
Description of problem: When Multus is upgraded it invalidates the primary CNI configuration on each node as it is upgraded. This causes unnecessary delays, and can result


How reproducible: During upgrades.


Additional info: One of the fixes for https://bugzilla.redhat.com/show_bug.cgi?id=1793635

Comment 1 Douglas Smith 2020-03-02 19:09:00 UTC
PR @ https://github.com/openshift/multus-cni/pull/52

Comment 4 Weibin Liang 2020-03-12 17:36:33 UTC
Tested and verified in 4.3.0-0.nightly-2020-03-12-085147

[root@dhcp-41-193 FILE]# oc get clusterversions
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-0.nightly-2020-03-12-085147   True        False         128m    Cluster version is 4.3.0-0.nightly-2020-03-12-085147

[root@dhcp-41-193 FILE]# oc rsh multus-bg99w
sh-4.2# cat /entrypoint.sh | grep -i invalid
sh-4.2# exit

Comment 6 errata-xmlrpc 2020-03-24 14:34:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.