Bug 1809285 - [4.4] Multus should not cause machine to go not ready when Multus is updated
Summary: [4.4] Multus should not cause machine to go not ready when Multus is updated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Douglas Smith
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On: 1809289
Blocks: 1809283
TreeView+ depends on / blocked
 
Reported: 2020-03-02 19:09 UTC by Douglas Smith
Modified: 2020-05-04 11:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1809283
: 1809289 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:43:52 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift multus-cni pull 53 0 None closed Bug 1809285: Removes configuration invalidation [4.4 backport] 2020-11-13 15:00:32 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:13 UTC

Description Douglas Smith 2020-03-02 19:09:53 UTC
+++ This bug was initially created as a clone of Bug #1809283 +++

Description of problem: When Multus is upgraded it invalidates the primary CNI configuration on each node as it is upgraded. This causes unnecessary delays, and can result


How reproducible: During upgrades.


Additional info: One of the fixes for https://bugzilla.redhat.com/show_bug.cgi?id=1793635

--- Additional comment from Douglas Smith on 2020-03-02 19:09:00 UTC ---

PR @ https://github.com/openshift/multus-cni/pull/52

Comment 3 Weibin Liang 2020-03-05 20:06:38 UTC
Tested and verified in 4.4.0-0.nightly-2020-03-05-100046

[root@dhcp-41-193 Network]# oc exec multus-5k5jr -- cat /entrypoint.sh | grep invalid
[root@dhcp-41-193 Network]# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-03-05-100046   True        False         5h23m   Cluster version is 4.4.0-0.nightly-2020-03-05-100046
[root@dhcp-41-193 Network]# 


Without fixed PR, cat /entrypoint.sh will show:
[root@dhcp-41-193 FILE]# oc exec multus-fp4rb -- cat /entrypoint.sh | grep invalid
        {Multus configuration intentionally invalidated to prevent pods from being scheduled.}
      log "Multus configuration intentionally invalidated to prevent pods from being scheduled."
          # But first, check if it has the invalidated configuration in it (otherwise we keep doing this over and over.)
          if ! grep -q "invalidated" $CNI_CONF_DIR/00-multus.conf; then

Comment 5 errata-xmlrpc 2020-05-04 11:43:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.