Bug 1809368 - [4.4] bump openshift/api to remove IPv6DualStack feature flag
Summary: [4.4] bump openshift/api to remove IPv6DualStack feature flag
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1809369
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-02 23:30 UTC by Dan Winship
Modified: 2020-05-04 11:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1809369 1809372 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:44:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 355 0 None closed Bug 1809368: bump openshift/api to remove IPv6DualStack feature flag 2020-08-11 10:25:49 UTC
Github openshift cluster-kube-controller-manager-operator pull 359 0 None closed Bug 1809368: bump openshift/api to remove IPv6DualStack feature flag 2020-08-11 10:25:49 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:44:42 UTC

Description Dan Winship 2020-03-02 23:30:24 UTC
There are bugs with the IPv6DualStack feature flag in 1.17/4.4 even in single-stack clusters. Bug 1794376 removed it from openshift/api and updated cluster-kube-apiserver-operator but didn't update cluster-kube-controller-manager-operator so we were still setting that flag for kcm.

Comment 4 zhou ying 2020-03-09 01:45:09 UTC
Confirmed with payload: 4.4.0-0.nightly-2020-03-08-213224, the issue has fixed:

[root@dhcp-140-138 ~]# oc rsh -n openshift-kube-controller-manager po/kube-controller-manager-ip-10-0-136-132.us-east-2.compute.internal

sh-4.2# cat  /etc/kubernetes/static-pod-resources/configmaps/config/config.yaml | python -m json.tool
{
 ...
        "feature-gates": [
            "RotateKubeletServerCertificate=true",
            "SupportPodPidsLimit=true",
            "NodeDisruptionExclusion=true",
            "ServiceNodeExclusion=true",
            "SCTPSupport=true",
            "LegacyNodeRoleBehavior=false"
        ],

Comment 6 errata-xmlrpc 2020-05-04 11:44:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.