Bug 1809572 - Templates page does not handle no-namespace situation gracefully
Summary: Templates page does not handle no-namespace situation gracefully
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Tomas Jelinek
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1793906
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 12:38 UTC by Tomas Jelinek
Modified: 2020-05-13 22:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
minor visual change, no need to document it
Clone Of: 1793906
Environment:
Last Closed: 2020-05-13 22:00:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4636 0 None closed [release-4.4] Bug 1809572: Align VM templates 'no project' page with VMs 2020-04-17 12:57:46 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:17 UTC

Description Tomas Jelinek 2020-03-03 12:38:47 UTC
+++ This bug was initially created as a clone of Bug #1793906 +++

Description of problem:
If the user goeys to the Virtual Machine Templates" page before a namespace is created, he will be confronted with an error (See screenshot).

Other pages i.e. Pod or Virtal Machines pages - are handling it more gracefully, Templates should align.

Version-Release number of selected component (if applicable):
CNV 2.1

How reproducible:
Always

Steps to Reproduce:
1. Login to OCP
2. Do NOT create a project/namespace
3. Go to "Virtual Machine Templates" page

Actual results:
Permission error is displayed

Expected results:
Similar handling like Virtual Machine page does if no project exists

Additional info:

--- Additional comment from Fabian Deutsch on 2020-01-22 09:03:45 UTC ---



--- Additional comment from Tomas Jelinek on 2020-02-07 11:45:56 UTC ---

Comment 3 Guohua Ouyang 2020-03-12 05:29:27 UTC
verified on 4.4.0-0.nightly-2020-03-06-170328

Comment 5 errata-xmlrpc 2020-05-13 22:00:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.