Bug 1793906 - Templates page does not handle no-namespace situation gracefully
Summary: Templates page does not handle no-namespace situation gracefully
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Phillip Bailey
QA Contact: Nelly Credi
URL:
Whiteboard:
: 1777292 (view as bug list)
Depends On:
Blocks: 1809572
TreeView+ depends on / blocked
 
Reported: 2020-01-22 09:02 UTC by Fabian Deutsch
Modified: 2020-07-13 17:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1809572 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
Bad: Templates (35.63 KB, image/png)
2020-01-22 09:02 UTC, Fabian Deutsch
no flags Details
Good: VM page (47.63 KB, image/png)
2020-01-22 09:03 UTC, Fabian Deutsch
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4584 0 None closed Bug 1793906: Align VM templates 'no project' page with VMs 2020-03-31 07:58:14 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:43 UTC

Description Fabian Deutsch 2020-01-22 09:02:58 UTC
Created attachment 1654494 [details]
Bad: Templates

Description of problem:
If the user goeys to the Virtual Machine Templates" page before a namespace is created, he will be confronted with an error (See screenshot).

Other pages i.e. Pod or Virtal Machines pages - are handling it more gracefully, Templates should align.

Version-Release number of selected component (if applicable):
CNV 2.1

How reproducible:
Always

Steps to Reproduce:
1. Login to OCP
2. Do NOT create a project/namespace
3. Go to "Virtual Machine Templates" page

Actual results:
Permission error is displayed

Expected results:
Similar handling like Virtual Machine page does if no project exists

Additional info:

Comment 1 Fabian Deutsch 2020-01-22 09:03:45 UTC
Created attachment 1654495 [details]
Good: VM page

Comment 2 Tomas Jelinek 2020-02-07 11:45:56 UTC
*** Bug 1777292 has been marked as a duplicate of this bug. ***

Comment 5 Guohua Ouyang 2020-03-31 09:01:58 UTC
there is only a "Virtualization" on 4.5, no such issue now.

Comment 7 errata-xmlrpc 2020-07-13 17:13:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.