Bug 1809646 - subscription_sync_count metric should contain package name
Summary: subscription_sync_count metric should contain package name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Anik
QA Contact: Tom Buskey
URL:
Whiteboard:
Depends On: 1809294
Blocks: 1809649
TreeView+ depends on / blocked
 
Reported: 2020-03-03 15:42 UTC by Anik
Modified: 2020-05-13 22:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1809294
: 1809649 (view as bug list)
Environment:
Last Closed: 2020-05-13 22:00:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1342 None closed [release-4.4] Bug 1809646: Update subscription_sync_count to include the package name 2020-07-10 17:07:30 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 22:00:23 UTC

Description Anik 2020-03-03 15:42:42 UTC
+++ This bug was initially created as a clone of Bug #1809294 +++

Description of problem:

The subscription_sync_total metric does not have the package name.

Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
The subscription_sync_total metric should have the package name. 

Additional info:

https://github.com/operator-framework/operator-lifecycle-manager/blob/master/pkg/metrics/metrics.go#L147-L152

Comment 3 Zhang Cheng 2020-03-09 12:16:17 UTC
Removed depend on bug 1809294 since it was moved to ON_QA status.

Comment 6 errata-xmlrpc 2020-05-13 22:00:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.