Bug 1809649 - subscription_sync_count metric should contain package name
Summary: subscription_sync_count metric should contain package name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.3.z
Assignee: Anik
QA Contact: Tom Buskey
URL:
Whiteboard:
Depends On: 1809646
Blocks: 1809661
TreeView+ depends on / blocked
 
Reported: 2020-03-03 15:54 UTC by Anik
Modified: 2020-04-03 00:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1809646
: 1809661 (view as bug list)
Environment:
Last Closed: 2020-03-24 14:34:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1343 None closed [release-4.3] Bug 1809649: Update subscription_sync_count to include the package name 2020-04-27 16:07:52 UTC
Red Hat Product Errata RHBA-2020:0858 None None None 2020-03-24 14:34:52 UTC

Description Anik 2020-03-03 15:54:39 UTC
+++ This bug was initially created as a clone of Bug #1809646 +++

Description of problem:

The subscription_sync_total metric does not have the package name.

Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
The subscription_sync_total metric should have the package name. 

Additional info:

https://github.com/operator-framework/operator-lifecycle-manager/blob/master/pkg/metrics/metrics.go#L147-L152

Comment 5 errata-xmlrpc 2020-03-24 14:34:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.