Bug 1809661 - subscription_sync_count metric should contain package name
Summary: subscription_sync_count metric should contain package name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.z
Assignee: Simran Dhaliwal
QA Contact: Tom Buskey
URL:
Whiteboard:
Depends On: 1809649
Blocks: 1820339
TreeView+ depends on / blocked
 
Reported: 2020-03-03 16:09 UTC by Anik
Modified: 2020-04-14 11:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1809649
: 1820339 (view as bug list)
Environment:
Last Closed: 2020-04-14 11:58:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1367 None closed Bug 1809661: Update subscription_sync_count to include the package name 2020-07-10 12:52:43 UTC
Red Hat Product Errata RHBA-2020:1398 None None None 2020-04-14 11:58:41 UTC

Description Anik 2020-03-03 16:09:35 UTC
+++ This bug was initially created as a clone of Bug #1809649 +++

Description of problem:

The subscription_sync_total metric does not have the package name.

Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
The subscription_sync_total metric should have the package name. 

Additional info:

https://github.com/operator-framework/operator-lifecycle-manager/blob/master/pkg/metrics/metrics.go#L147-L152

Comment 5 errata-xmlrpc 2020-04-14 11:58:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1398


Note You need to log in before you can comment on or make changes to this bug.