Bug 1810986 - `oc adm inspect namespace` doesn't collect pod logs
Summary: `oc adm inspect namespace` doesn't collect pod logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: unspecified
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1810987
TreeView+ depends on / blocked
 
Reported: 2020-03-06 10:55 UTC by Ashish Ranjan
Modified: 2020-07-13 17:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:18:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:19:10 UTC

Internal Links: 1810987

Description Ashish Ranjan 2020-03-06 10:55:08 UTC
Description of problem:
The `oc adm inspect namespace` doesn't collect logs of all pods running presently in the namespace. 

Version-Release number of selected component (if applicable):
v4.5.0

How reproducible:
Run `oc adm inspect ns/<ns-name>` for a namespace having more the 10 pods and verify the logs.


Actual results:
The logs are missing for some of the pods present in the namespace.

Expected results:
The logs must be present for the pods present in the namespace.


Additional info:

Comment 4 zhou ying 2020-03-09 06:46:18 UTC
Confirmed with latest oc client, the issue can't be reproduced:
[yinzhou@localhost test]$ oc version -o yaml
clientVersion:
  buildDate: "2020-03-06T23:07:39Z"
  compiler: gc
  gitCommit: 8ce61268781d2074158d05ad11141792b94b1910
  gitTreeState: clean
  gitVersion: 4.5.0-202003062301-8ce6126
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

[yinzhou@localhost test]$ oc adm inspect namespace/zhouy
Gathering data for ns/zhouy...
Wrote inspect data to inspect.local.5042766254579610156.
[yinzhou@localhost test]$ tree inspect.local.5042766254579610156/
inspect.local.5042766254579610156/
└── namespaces
    └── zhouy
.....
        ├── pods
        │   ├── jenkins-1-deploy
        │   │   ├── deployment
        │   │   │   └── deployment
        │   │   │       └── logs
        │   │   │           ├── current.log
        │   │   │           ├── previous.insecure.log
        │   │   │           └── previous.log
        │   │   └── jenkins-1-deploy.yaml
        │   ├── jenkins-2-d7szj
        │   │   ├── jenkins
        │   │   │   └── jenkins
        │   │   │       └── logs
        │   │   │           ├── current.log
        │   │   │           ├── previous.insecure.log
        │   │   │           └── previous.log
        │   │   └── jenkins-2-d7szj.yaml
        │   └── jenkins-2-deploy
        │       ├── deployment
        │       │   └── deployment
        │       │       └── logs
        │       │           ├── current.log
        │       │           ├── previous.insecure.log
        │       │           └── previous.log
        │       └── jenkins-2-deploy.yaml

Comment 6 errata-xmlrpc 2020-07-13 17:18:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.