Bug 1810987 - `oc adm inspect namespace` doesn't collect pod logs
Summary: `oc adm inspect namespace` doesn't collect pod logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1810986
Blocks: 1810959
TreeView+ depends on / blocked
 
Reported: 2020-03-06 10:59 UTC by Ashish Ranjan
Modified: 2020-05-04 11:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:45:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1810986 None None None 2020-03-06 10:59:12 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:45:22 UTC

Description Ashish Ranjan 2020-03-06 10:59:12 UTC
Description of problem:
The `oc adm inspect namespace` doesn't collect logs of all pods running presently in the namespace. 

Version-Release number of selected component (if applicable):
v4.4.0

How reproducible:
Run `oc adm inspect ns/<ns-name>` for a namespace having more the 10 pods and verify the logs.


Actual results:
The logs are missing for some of the pods present in the namespace.

Expected results:
The logs must be present for the pods present in the namespace.


Additional info:

Comment 3 zhou ying 2020-03-09 06:35:08 UTC
The issue has fixed:

[zhouying@dhcp-140-138 logs]$                   oc version -o yaml 
clientVersion:
  buildDate: "2020-03-05T14:37:15Z"
  compiler: gc
  gitCommit: 2576e482bf003e34e67ba3d69edcf5d411cfd6f3
  gitTreeState: clean
  gitVersion: 4.4.0-202003051431-2576e48
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64
[zhouying@dhcp-140-138 ~]$ oc adm inspect namespace/zhouy
Gathering data for ns/zhouy...
Wrote inspect data to inspect.local.880042931334620758.

[zhouying@dhcp-140-138 ~]$ tree inspect.local.880042931334620758/
inspect.local.880042931334620758/
└── namespaces
    └── zhouy
...
        ├── pods
        │   ├── jenkins-1-deploy
        │   │   ├── deployment
        │   │   │   └── deployment
        │   │   │       └── logs
        │   │   │           ├── current.log
        │   │   │           ├── previous.insecure.log
        │   │   │           └── previous.log
        │   │   └── jenkins-1-deploy.yaml
        │   ├── jenkins-2-d7szj
        │   │   ├── jenkins
        │   │   │   └── jenkins
        │   │   │       └── logs
        │   │   │           ├── current.log
        │   │   │           ├── previous.insecure.log
        │   │   │           └── previous.log
        │   │   └── jenkins-2-d7szj.yaml
        │   └── jenkins-2-deploy
        │       ├── deployment
        │       │   └── deployment
        │       │       └── logs
        │       │           ├── current.log
        │       │           ├── previous.insecure.log
        │       │           └── previous.log
        │       └── jenkins-2-deploy.yaml
        ├── route.openshift.io
        │   └── routes.yaml
        └── zhouy.yaml

23 directories, 33 files

Comment 5 errata-xmlrpc 2020-05-04 11:45:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.