Bug 1811031 - Independent mode dashboard shows erroneous metrics
Summary: Independent mode dashboard shows erroneous metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Bipul Adhikari
QA Contact: Ankush Behl
URL:
Whiteboard:
Depends On: 1810535
Blocks: 1843518
TreeView+ depends on / blocked
 
Reported: 2020-03-06 13:07 UTC by Bipul Adhikari
Modified: 2020-10-27 15:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1810535
Environment:
Last Closed: 2020-10-27 15:56:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
No Metrics (165.98 KB, image/png)
2020-05-24 18:56 UTC, Oded
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4674 0 None closed [release-4.4] Bug 1811031: Independent Dashboard is not showing correct metrics 2020-09-07 09:03:46 UTC
Github openshift console pull 5575 0 None closed Bug 1811031: Change dashboard activation mechanism 2020-09-07 09:03:46 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:56:34 UTC

Description Bipul Adhikari 2020-03-06 13:07:37 UTC
+++ This bug was initially created as a clone of Bug #1810535 +++

Description of problem:
Dashboard metrics are not seen due to wrong queries.


Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:1/1


Steps to Reproduce:
1. Go to Persitent Storage Dashboard on Independent Mode Cluster
2.
3.

Actual results:
Metrics not shows

Expected results: 
metrics shown


Additional info:

Comment 4 Oded 2020-05-17 13:50:37 UTC
Independent mode should not be visible on OCP 4.4 (since OCS 4.4 doesnt support it)

Comment 5 afrahman 2020-05-18 06:14:29 UTC
Re-targeting to 4.5, since feature pushed to 4.5

Comment 6 Oded 2020-05-24 18:53:26 UTC
Bug Reconstructed
Setup:
Provider:AWS
OCP Version:4.5.0-0.nightly-2020-05-24-072501
OCS Version:ocs-operator.v4.5.0-433.ci

Test Process:
1.Go to Persitent Storage Dashboard on Independent Mode Cluster
2.Metrics not shows
*attached screen shot

Comment 7 Oded 2020-05-24 18:56:53 UTC
Created attachment 1691620 [details]
No Metrics

Comment 9 Bipul Adhikari 2020-05-27 12:53:06 UTC
To solve this issue. We are making the Persistent and Object Service dashboard dynamic so that dashboard gets loaded only when the storage cluster is created. Metrics should come one the storage cluster is in the ready state.

Comment 12 errata-xmlrpc 2020-10-27 15:56:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.